Razer Synapse 3 is not detecting Razer Mamba Chroma & BlackWidow

Discussion in 'Razer Support' started by -Drakan-, Mar 21, 2020.

Thread Status:
Not open for further replies.
  1. -Drakan-

    -Drakan- New Member

    Shout-out to the community!
    I've been experiencing this problem for quite a while and since Synapse 3 is in a long time BETA release I never wanted to raise the topic but it's been quite a while since then and I feel that it has to be addressed.

    The 2 devices I am using are:

    Razer BlackWidow (original ver)
    [​IMG]
    Razer Mamba Chroma
    [​IMG]

    Based on the official support list here both devices should be supported!? While I have a small doubt about my mouse since it's not the latest edition (it's been already 3 years) it clearly mentions the original BlackWidow keyboard. It doesn't seem like a driver issue since both of my devices were immediately recognised by Windows 10 and updated with their drivers respectively. I tried to repair the software as stated by the troubleshooting article and uninstalled both my drivers and Synapse with no success. As an optional step I tried to use Mamba just wireless mode hoping that the dock will be synced but it didn't help either.

    As of now Razer Synapse 2.0 is the only one that works for both devices but all of the updates are done to the new platform. Having a flagship mouse for £135 (RRP at the time of purchase) as well as premium keyboard such issues are really showing poor support as it should work flawlessly at least on the essentials.

    Has anyone experienced similar issue? What can be the cause for not detecting officially supported devices?
     
    Last edited: Mar 26, 2020
  2. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    That list does need to be polished. The BlackWidow listed on the link you provided isn't actually the OG, but one of the newer releases. Based on the images of the devices you shared, both are not supported on Synapse 3. Do send me a PM with the serial numbers of the devices so I can verify it.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >