Razer Synapse 3 won't start

Discussion in 'Razer Support' started by WellItsPaul, Jan 31, 2019.

Thread Status:
Not open for further replies.
  1. WellItsPaul

    WellItsPaul New Member

    Hey!
    First of all: I'm from germany and I'm sorry if my english is not the best.
    My problem is that razer synapse 3 just won't start anymore..
    I tried to do a clean reinstall with revo uninstaller but it's still not opening.
    I tried everything but it's not working.
    It always says "Razer Synapse is not active" and if I click on the "Start Razer Synapse" button the little loading thing shows up for a second, disappears and nothing happens..
    I seriously don't know what's wrong with synapse.
    Maybe I just have to wait for another update.

    Paul
     
  2. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Hi Paul! Please try to reinstall Microsoft .NET Framework and send me a PM if the problem persists.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >