Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Razer Tartarus Pro Not Working

Discussion in 'Razer Support' started by shubhankarsahu, Jan 4, 2020.

Thread Status:
Not open for further replies.
  1. shubhankarsahu

    shubhankarsahu New Member

    brought Razer Tartarus pro a month back it took me some time to get use to it and configure all the keys and commands as per my requirements. finally when i was done configuring it and made two profiles one for game and one for windows. unfortunately it did not work as expected none if the macro or profile is working.
    when i connect Tartarus Pro it for a while and stops working. i press button to change profile, it only shows changes being made on the screen in Synapse 3 software but Tartarus Pro does not work or show any effect.
    i have tried dummy account, connecting disconnecting device multiple time on different ports and PC, Tried resetting device, logging in and out Synapse 3 software.

    attached video link showing the issue.

    https://1drv.ms/v/s!And5cR3G4wxZqhJCaw1sI9_1GQQU?e=Kc4zLL

    https://1drv.ms/v/s!And5cR3G4wxZqhHI0v5mlHKwRR09?e=Pv1uTm

    https://1drv.ms/v/s!And5cR3G4wxZqhD6lIFA1BH7jSlJ?e=RX9teO
     
  2. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hi there! Please PM me the serial number of your Tratarus Pro. I'll take it from there.
     
  3. shubhankarsahu

    shubhankarsahu New Member

    i have mailed to support team and have tried every thing possible and as suggested by support team but still no solution,
    i posted this here in hope if any member could help me out or to know if anyone else is facing same issue.

    last reply i got is "You’re in good hands now! Please do give us some time within the next 24-48 hours for them to attend to you. We will get it sorted out for you."
    so waiting for further update its already 18 hrs or so, I'm still trying to get it work out. till now i have done like 3 to 4 clean installation of Synapse in hope. now just waiting for reply from support team
     
  4. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Thanks for the reply. Please PM me the case number so I can take a look.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >