razer viper stop working every few seconds

Discussion in 'Mice and Surfaces' started by Tiesse, Jul 24, 2022.

  1. Tiesse

    Tiesse New Member

    it's been now more than a week with my mouse stopping every about 10/20 sec or even less i tried anything from changing usb on the pc to unistalling multiple times the mouse software but nothing changes. Is there anyone with the same problem/who knows how to solve it?
     
    pancholr likes this.
  2. Sye_The-Vie

    Sye_The-Vie Well-Known Member VANGUARD

    10/20 sec? that is 0.5 seconds :wink_::wink_::wink_:

    or did you mean 10 to 20 seconds?
     
  3. Tiesse

    Tiesse New Member

    yes i mean 10 to 20 not half a second
     
  4. Sye_The-Vie

    Sye_The-Vie Well-Known Member VANGUARD

    Also what kind of Viper do you have?
    • Viper
    • Viper Mini
    • Viper 8Khz
    • Viper ULT
    Check out the following link to update the firmware version

    https://drivers.razersupport.com//index.php?_m=downloads&_a=view&parentcategoryid=76&pcid=0&nav=0

    Also the factor of mouse delay can lie within the OS or Synapse side of things
    • Are you using Windows 10 or 11?
    • Have you updated the Windows with latest update?
    • Have you updated Synapse 3.0 version?
    • Does your PC have a Virus?
    Some rare cases, if you have a bad hardware (Old AMD CPUs) can cause the Synapse to disfunction.

    All these factors must be considered to narrow down the issue
     
  5. Tiesse

    Tiesse New Member


    i have a razer viper (the normal wired version) i am still using windows 10, it's updated, right now i don't have synapse cause when it was installed it seems like the issue was more frequent and i'm don't have virus in my pc

    PS. it's not like a delay. my mouse just stop working for a couple of seconds, this thing happen about every 10 or 20 seconds or even less. sometimes it also turn off the lighting and i need to unplug an plug again the usb to use it again
     
  6. Sye_The-Vie

    Sye_The-Vie Well-Known Member VANGUARD

    try plugging to a different Windows PC.
    Any PC that works like normal, see if it makes a difference
    • If the Viper is working normal, than your previous PC needs to be investigated
    • If the Viper is showing the same symptoms, than raise a query to RAZER's official support and see what they can do
     
  7. -Mr.Nobody-

    -Mr.Nobody- Well-Known Member

    it happen to me while a ago, what i did was

    reset the mice from synapse
    then uninstall it from Device Manager.
    unplug the Viper
    restart your pc
    plug back in the Viper and let Razer synapse update your Viper
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >