Razer Viper Ultimate Battery % Won't Increase

Discussion in 'Razer Support' started by VividAuburnrushsecret774, Feb 8, 2022.

Thread Status:
Not open for further replies.
  1. Since yesterday my Razer Viper Ultimate refuses to charge, the battery level won't increase. I've tried directly with the cable, using the dock, re-installing Synapse, and even using another computer without synapse where it still showed low battery even after being plugged in for about an hour. I've also tried things such as having the mouse powered off for 30~ minutes before attempting to charge, still nothing.

    I'm out of my warranty period so I'm out of luck in terms of getting a replacement. The mouse works fine when plugged in, but I bought it primarily because it's wireless so if there's any way to get this battery out of it's "stuck" state I'd be ecstatic. Has anyone had any similar issues?

    Thanks for anyone who's able to help!
     
  2. Razer.JaqenHgar

    Razer.JaqenHgar Retired

    There is no battery replacement available for Razer Viper Ultimate yet, and you pretty much have covered the suggested troubleshooting from our support site. With that, I bear the stamp of performing a firmware update to see if it fixes the charging issue. Just send me a PM with the serial number to verify the exact firmware updater for your device.

    Thread locked to curb the conversation to PMs.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >