Razer Wireless Headset static/buzzing issues

Discussion in 'Audio' started by VictorLaw520, Apr 8, 2022.

Tags:
Thread Status:
Not open for further replies.
  1. VictorLaw520

    VictorLaw520 New Member

    Hi All,

    I've purchased a Razer BlackShark v2 Pro Wireless and it's my very first wireless headset. Solid headset but I've noticed an issue when I turn the volume via the volume knob, whenever its too high or too low, the headset will emit a constant static/buzzing noise on the right side of the earcup. I've tried everything in attempt to solve the issues, however all to no avail. I list down the stuffs that I've tried in attempt to solve the issue.

    1. Update Firmware
    2. Connect to different device to test and test with different USB ports
    3. Uninstall and reinstall Razer Synapse
    4. Disable all audio enhancement

    is there any solution to this ? If not, is this something that I can request Replacement (got this headset two days ago) ?

    Thanks in advance and have a good day.
     
    ShadowWolf32387 and Rompomponix like this.
  2. Rompomponix

    Rompomponix New Member

    I have the same problem.
     
  3. Edje000

    Edje000 New Member

    I have the exact same problem. Just got mine today and have tried everything with no luck.
     
  4. CarolBrusteredman

    CarolBrusteredman New Member

    I have the same headset and there is a ringing noise that's more noticeable when my microphone is on. I believe it's normal.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >