Razor Blade Pro 17 - Power-up issue

Discussion in 'Razer Support' started by ewilley88, May 16, 2019.

Thread Status:
Not open for further replies.
  1. ewilley88

    ewilley88 New Member

    So, the first couple times this has happened to me I tried the google answers of playing the the power block to “change the power-state” of the battery. This has worked up until today when I left the laptop unplugged last night hoping to get a smooth start up today, no dice. I’ve been trying to reseat the power multiple times and still there is no response. I’ve carefully tried reseating the battery and Ram cards. I’m now keeping it plugged in to see if I can trick the battery.

    0 response, no lights, just seemingly completely bricked.

    It’s an older GTX 1060 series, but I bought it just a few months ago, love the product otherwise. Please help.
     
  2. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hi there! When did this start to happen? Also, does the power brick's LED indicator light up when you plug it in? Let me know.
     
  3. ewilley88

    ewilley88 New Member

    I think it started happening about a month after I purchased the older model of the Blade Pro 17" GTX 1060 back in december. The LED on the power block is lit up.

    The issue itself is definitely one others have experienced, I'm just not super ok with having to mess with my computer for minutes or hours (when the "fix" doesn't just work) just to turn it on.

    I put in a customer service ticket where the issue was explained, I'm just hoping that there is a fix and this isn't a brushed off known defect.
     
  4. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Thanks for the reply. Please PM me the case number so I can check. Let's continue there.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >