Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

reWASD can cause problems with Synapse detecting Razer hardware

Discussion in 'Razer Support' started by Phantorang, May 1, 2019.

Thread Status:
Not open for further replies.
  1. Phantorang

    Phantorang New Member

    tl;dr reWASD software made Synapse unable to recognise my Orbweaver, if you got trouble with Synapse and got reWASD (or maybe something like it), try to temporarily disable it while you get razer synapse to work, then enable it again.

    So much trouble, but so easy solution.
    3 weeks ago I couldn't get into Razer Synapse and change settings for my Orbweaver, Synapse didn't seem to detect the Orbweaver, even though it showed up on Device Manager, and the default buttons worked. But what's the point with an Orbweaver if the buttons can't be reprogrammed.

    So I tried everything, was in touch with support (they were nice and tried their best), but I just couldn't get the Orbweaver to be seen by Synapse. I installed and reinstalled several times until I gave up, took to many hours.

    But I like my Orbweaver, I got frustrated over the finger gymnastics I had to do to play certain games, so I had to do a retry.

    So I uninstalled everything, reinstalled, didn't work. Tried a bit harder, went into the registry and picked out everything with Razer in it and did a thorough search, finally everything gone, followed the instructions on how to do a clean install, disable virus software, defender and firewall, still didn't work. Frustrating.

    But then I remembered I downloaded reWASD, because I wanted to properly reprogram my Xbox Elite controller, I thought maybe if I turn that off synapse will work. And loathe and behold, it did, Finally!

    Happy ending.
     
    Last edited: May 2, 2019
  2. PT.Singer

    PT.Singer Jedi Master VANGUARD

    I'm trying to figure out if this is a request for support, or a PSA about using Synapse with reWASD installed ...
     
  3. Phantorang

    Phantorang New Member

    I searched everywhere for someone with the same issue, the one I found had no solution to the problem, I just thought if someone else had the same issue, it was nice to find a post from someone who had same problem. But if it doesn't belong here, you can delete it.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >