Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Ripsaw Audio Glitching?

Discussion in 'Razer Support' started by BethanyOfMight, Aug 5, 2020.

Thread Status:
Not open for further replies.
  1. BethanyOfMight

    BethanyOfMight New Member

    Hello! I've tried everything I can think of to resolve this issue, and I am out of ideas. Any help would be greatly appreciated!

    Basically, my Ripsaw has developed a strange issue in the past week where the audio is missing everything other moment/note/whatever you want to call it. This issue only happens for the actual audio capture itself, and has no impact on the sound coming from my TV speakers themselves. It persists whether I'm in a game, or just sitting on the home screen of my PS4. It also is only for game audio, and has not shown up for my mic as of yet.

    So far, I have restarted my computer; installed all possible updates my laptop and the Ripsaw software has recommended; uninstalled and reinstalled the Ripsaw software; changed out the HDMI cables; set the Streamlabs OBS and the Ripsaw to 60 FPS, and restarted again; and nothing has worked yet. I'm not sure what else I can do from here, besides just replacing the Ripsaw and hoping that fixes it.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >