Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

RP 2 fingerprint not working

Discussion in 'Mobile' started by greatOldMossGreenzone013, Jun 22, 2020.

  1. Hi All,

    2 days ago suddenly my fingerprint stopped working on my razer phone 2, I was getting this error "Cannot process fingerprint" and "fingerprint hardware not available" I opened my phone with my alternative security key and tried to delete/add new fingerprints, after few unsuccessful trials I was able to add the fingerprints again. Still, I was getting this error "fingerprint enrollment didn't work" many times before it worked.

    After that, the fingerprint worked completely fine for a few mins and back to the same issue again! Each time I tried to reset the fingerprint settings, it worked for a while and back to the same issue again.

    I tried to clean the sensor, hard reboot (8-10 times), scan for malware and viruses and test it in the soft mode, but unfortunately, nothing worked :slightly_sad:

    Currently, the fingerprint is not working at all, and I'm not able to add the fingerprints again, even if I hard reboot the phone.

    I'm very desperate and really tired of trying fixing this.

    Does anyone have any suggestions?

    *Last system security update was on March 5, 2020, and the Andriod version is 9
     
    pancholr likes this.
  2. [Update]

    I got a security update on 5-Jul and the fingerprint option has been disappeared completely from the phone.

    Still, no one helped from Razer's support.
     
  3. Xemos

    Xemos New Member

    Also have this problem since yesterday... on Razer Phone 2
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >