[Solved] Basilisk V3 Pro: Bluetooth problems

Discussion in 'Mice and Surfaces' started by UNIQSON, Nov 10, 2022.

  1. UNIQSON

    UNIQSON New Member

    Hello,

    I am no longer able to find my Basilisk V3 Pro via Bluetooth. But I could already connect it to my Steamdeck. However, today when I wanted to connect my mouse via bluetooth also with my laptop times, I could not find it. I thought I would have to unpair the mouse with the Steamdeck first to be able to find and use it on another device. Hopefully that's not the case and I can actually pair it with multiple devices at once and then switch quickly and easily via the profiles. So then I unpair the mouse from the Steamdeck, but I still couldn't find it on the laptop. And then I couldn't find it via the Steamdeck either.

    The first time I paired the mouse with the Steamdeck, I didn't have a firmware update applied. So I guess that must have caused the problem.

    I have also already reset my mouse. Does not bring anything.

    Does anyone have an idea or the possibility to check it with his mouse (with latest firmware update). Of course only if you do not rely on Bluetooth.

    Greetings from Berlin

    UNIQS
     
  2. thlobato

    thlobato New Member

    Mode selector
    As mentioned earlier, Deathadder v2 Pro uses two different methods of wireless connectivity:

    • Hyperspeed
    • Bluetooth
    The mouse uses only one of the two methods at any given time.

    To enable Bluetooth connectivity, make sure that you’ve selected BT under the mouse using the slider switch.



    [​IMG]
    Select BT mode
    If it’s set to either 2.4 or OFF, it won’t be able to pair with Bluetooth.

    Bluetooth Pairing
    If you’ve removed the mouse from your Bluetooth devices on your PC, the mouse could still be in a mode where it ‘thinks’ it’s still connected. If this is the case it won’t broadcast messages.

    Press and hold both side buttons and dpi-up button at the same time for three seconds to put the device in pairing mode. The logo should blink twice in repeated intervals to indicate that it is in pairing mode.

    Your PC should now be able to see the mouse again for re-pairing when you search for it.

    [​IMG]
    When the mouse has paired, the Razer logo will briefly turn solid blue before displaying its lighting effect.

    Bluetooth connectivity is limited to 30 feet. However in practice, depending on other wireless devices nearby, the range can be limited to less than that. To ensure better signal quality, move the mouse closer to your PC.

    If you encounter issues with Bluetooth pairing, try pairing with another Bluetooth device such as an external speaker. If it doesn’t work then there’s likely an issue with Bluetooth on your PC.

    Try Another Computer
    To rule out Bluetooth issues with your PC try pairing the mouse with another PC or Mac. If it works, then it’s most likely an issue with your PC.

    Some common things to check for:

    • Did you update Windows recently? If so, you might have to roll back the update to see if that caused the issue
    • Are the Bluetooth drivers updated?
    • Although unlikely, it could also be a failure of the Bluetooth chip in your PC.
    Deathadder V2 Pro Keeps Disconnecting
    One common reason for this is interference due to other wireless devices (Wi-Fi routers, phones or microwave ovens) operating nearby. The other major cause of interference is USB 3.0 devices which are very noisy from a Radio perspective. This results in more interference (especially when they are in heavy use) which in turn disrupts the Bluetooth communication link.

    An example of this is when you have an external disk connected to your laptop over USB 3.

    [​IMG]
    USB3 peripheral connected to USB3 interface connector on PC (Image credit: Intel)
    Pause the use of the USB 3 device and see if it improves the quality of your Bluetooth connection. As well, move wireless routers, phones and other wireless devices away from your mouse.

    If the connection is more stable, then the problem was definitely due to interference. The only way to solve this permanently is to be mindful of other wireless devices nearby.

    Final suggestions
    If you have tried all the suggestions in our post and none of them worked, it might be worthwhile to contact support at Razer. If your mouse is still under warranty you can ask to RMA it.
     
  3. UNIQSON

    UNIQSON New Member

    Was able to solve the problem thanks to a post in another thread.

    The only difference in the graphics is that the Deathadder v2 Pro shown requires the two side buttons + the DPI button to be pressed for 3 seconds. With the Basilisk V3 Pro, however, you have to press both side buttons + the mouse wheel for 3 seconds to make the mouse findable again.


     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >