Stupid Restart Tanked Performance... Help?

Discussion in 'Razer Support' started by luptaaco, Jan 15, 2021.

Thread Status:
Not open for further replies.
  1. luptaaco

    luptaaco New Member

    Hey gang, would be super thankful if I could get any help on this. I got my Razer Blade (15" base model 2018) back in 2019, and it was great for playing the kind of games I liked. The performance worked really well for me. Then, around October of 2020, I decided to do a fresh wipe on my PC in case of malware as the performance had dropped a bit and I was worried about some features not working. I finished the wipe, and reinstalled all the required drivers and Razer apps. Since then my performance has absolutely tanked. The computer gets wildly hot when trying to play anything to the point that it becomes uncomfortable to play as my wrists get too hot, and playing medium-graphics Overwatch for more than 45 minutes causes the performance to become unplayable. Everything lags to an absurd degree now. But I mean, at least I know I'm safe from malware, right? Sigh.
    Is there any way I can fix this? I use this laptop for most everything and not being able to use it anymore for gaming blows, big time.
    Thanks!
     
  2. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Temp issues are usually caused by the lack of airflow inside the case. Have you tried opening the laptop for a cleaning session? Those dust bunnies can stomp on your FPS given time to grow enough to clog the vents. Send me the serial number if the problem persists.

    *Thread locked to curb the conversation to PMs.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >