Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Synapse 3 Macro Problem

Discussion in 'Razer Support' started by TheSho21, Nov 23, 2019.

Thread Status:
Not open for further replies.
  1. TheSho21

    TheSho21 New Member

    Hi all,

    FYI - Running Widows 10 Pro with a Blackwidow Elite (Orange Switches) and the Naga Trinity (12 button side attachment).

    I'm going to describe this as best I can:

    I like using multiple virtual desktops on Windows 10. However the shortcut for moving between the two is quite cumbersome ("windows button" + "cntrl" + "right arrow" or "left arrow" depending on the direction you want to go). So I decided I'd setup a macro for one of the side mouse buttons.

    So I click the Macros tab in Synapse and start the process. First I "record" the aforementioned key presses then assign it to the number 4 button on the side. I set it to "Play Once" I test it out and all seems well.

    I go into my browser and notice that essentially the left arrow button (or the right, tried both ways and it's always the last button that gets "stuck" down) is continuously being pushed down. I cannot do anything to stop it, including going into task manager and killing Synapse. The only way I could get it to stop is by resetting the computer.

    Am I doing something wrong? Is there a better way to setup this macro?

    Any help would be appreciated.
     
  2. TheSho21

    TheSho21 New Member

    No one else has encountered this issue?
     
  3. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hi there! Are you still having the same issue? Can you share a video of it?
     
  4. Buckaroo64

    Buckaroo64 New Member

    I have a similar issue. After using a macro assigned to a key it will execute the macro then the keyboard acts like the right arrow key is stuck. And restarting the pc stops it. It was working great and now every time I use a macro it does the same thing. Uninstalling and trying a reinstall.
     
  5. Buckaroo64

    Buckaroo64 New Member

    Well after installing and uninstalling that did not correct the issue. What did fix the issue was to delete the effected macros and make new ones. Something in the macro is being corrupted and is causing the windows keyboard driver issues.
     
  6. intelhonda20

    intelhonda20 New Member

    None of this helped, my problem is that the macro sequence finishes, and then its like the left click button is permanently on.
     
  7. Buckaroo64

    Buckaroo64 New Member

    Shortly after what I did Microsoft updated the HID keyboard driver. And I am still not having the same issue. But my keyboard was doing the very same thing just with the right arrow key. So I am not sure if it was anything I did or if it was the HID driver microsoft updated. So you might want to try uninstalling the HID driver then reinstall through update.
     
  8. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Can you share a photo of the macro that you are trying to use? Please try to reinstall Synapse and use another account or create a new macro to isolate the issue. Let me know how it goes.
     
  9. hi
    i have a razer viper ultimate
    macro not working leftclick hold, mousemovement, and when i realsse assigned button it still keeps holding the left click but the macro should immideatly stop after release
    need to set this with xml script when possible but with my logitech g proluascript it works fine, can we make this with xml?
     
  10. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hi there! Can you share a video of the issue? You can upload it somewhere like Google Drive and then PM me the link. I'll assist you from there.
     
  11. cant pm u it say error
    simple macro leftclick, mousemovement. the left click needs to be on hold, and when i assign this macro by button on hold it should stop after release. i can send u teamviewer try this on ur own synapse it still holds the button after u reallsea button

    i can send u the simple lua script and u can send me back in xml?
     
  12. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Thanks for the reply. Have you tried assigning the mouse function instead of a macro? A video would be best so I can completely replicate the macro that you were trying to use. By the way, what error message pops up when you try to send me a PM? You can use this link to PM me.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >