Synapse 3 not linking games?

Discussion in 'Razer Support' started by classicVividRedbyte503, Jul 17, 2019.

Thread Status:
Not open for further replies.
  1. Purchased a Naga Trinity as an update from my old Naga... the trinity only seems to work with synapse 3.0? That's fine, honestly, I don't care either way, though I want to be able to set it so that some of the extra keys function as back and forward in web and file browsing, but alt and shift in games. I figured the best way to do this would be creating two profiles and adding the games I want to the gaming profile. However, when I attempted to do this, I can find the game I want, hit link, and nothing happens. There's no confirmation, and exiting back shows that the game wasn't linked. I've tried this with a few games, and even tried manually finding the game's files, to the same effect. Is this a known issue? Any better ideas, or ideas how to fix this? Thanks.
     
  2. centralPhloxbuzz049

    centralPhloxbuzz049 New Member

    Got the same issue, cant add any game to synapse 3 listing dont work even manually
     
  3. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Hi everyone! Thanks for posting your Razer Synapse concern here. And yes, that is strange. Please send me a PM together with a photo or video that you are getting while linking a game. Let's continue there.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >