Synapse 3 update stopped it recognising devices

Discussion in 'Razer Support' started by LynneH1965, Jun 10, 2021 at 6:23 AM.

  1. LynneH1965

    LynneH1965 New Member

    I have a Nari Ultimate headset and a base station V2 Chroma. The base station was randomly disconnecting and RGB stopped working and it was not recognised by Synapse, but at this point the headset was still working. Then the headset also started randomly disconnecting, but was still recognised on Synapse when it reconnected.

    At this point I started searching for solutions and I went through the support page, repairing Synapse then rebooting, but the problem was still there. I then noticed there was an update pending, so I downloaded and installed it. I rebooted and now Synapse doesn't recognise either device.

    I've only had these two for 10 days and I pretty annoyed I am having problems so soon, perhaps I should have paid more attention to the negative reviews for the base station. I was about to buy a new NAGA mouse, but if I can't get this sorted I am loath to give Razer any more money.

    TLDR
    Synapse doesn't recognise Nari Ultimate or V2 Chroma
    Yes, I have repaired Synapse
    Yes, I have rebooted
    Yes, I have installed a pending update
    Yes, I have rebooted
    Yes, I have watched the video on your support page
    No, I don't rate Razer right now and seeing as how there are reams of pages of people with this problem, why haven't you addressed the issue

    If this isn't sorted, I will return both products to Amazon for a refund, I will not claim through the warranty and I will let Amazon sort this out with you directly
     
  2. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Have you received any Windows updates recently? Did you try to perform a clean reinstallation of Synapse? Make sure that your anti-virus or firewall is not blocking any Razer-related files or apps when you are trying to update. Also, have you installed the latest Razer Nari Ultimate pairing utility and recovery tool? Please update your Windows .NET Framework too and see if it helps.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >