Synapse failed to start....

Discussion in 'Razer Support' started by Superthrust, Jun 7, 2019.

  1. Superthrust

    Superthrust New Member

    Cortex, synapse, all of it. Failed to start. Tried repairing, nothing worked.

    How about we solve this outside of a PM in case people have this issue in the future...?

    Last thing I knew, I was updating and when I restarted my pc due to a synapse and cortex update, it does not open since.
     
  2. Lauriat

    Lauriat Title: Entitled

    Those whom I talked to in PM somehow had this issue fixed by performing a clean reinstallation of Synapse. You can try this by following the steps below:

    1. Uninstall Razer Synapse from your PC and delete all files in C:\Program Files (x86)\Razer and C:\ProgramData\Razer directories. These folders may be hidden by default, so please be sure to unhide them. We want to ensure that there are no residual files remaining that may corrupt your installation. This is important so please do so. Restart your computer afterward.
    2. Go into device manager, go to Keyboards/Audio inputs and outputs/Mouse and other pointing devices, uninstall HID Keyboard/Mouse Drivers and all other Razer product drivers, and restart your PC. Be sure to select delete drivers as well when uninstalling. Restart your computer again.
    3. Turn off all Firewall and Anti-virus software to prevent any conflicts. Download and install the latest version of Microsoft .NET Framework (4.5 or higher) at http://www.microsoft.com/en-us/download/details.aspx?id=30653 (In some cases, you may need to uninstall the older version on your system). Restart your computer again.
    4. Install the latest version of Razer Synapse that can be downloaded from http://rzr.to/synapse-3-pc-download.

    If this doesn't work, just let me know.
     
  3. MKLO94

    MKLO94 New Member

    I have the same problem too,and doesn't work for me
     
  4. monnnytes

    monnnytes New Member

    it didnt work
     
  5. Lauriat

    Lauriat Title: Entitled

    How about your OS? Are they fully updated?
     
  6. MarkingX2

    MarkingX2 New Member

    I've gone through the steps multiple times still no fix.
     
  7. testpilot932

    testpilot932 New Member

    Very unimpressed with your software and implementation. Get your $%#@ together. At this point I am done with Razer products and intend to share my experiences.
     
  8. leetcoastStizza378

    leetcoastStizza378 New Member

    I just bought a Razer Blackwidow 2019 and DeathAdder Elite. I tried to install Synapse 3.4.0711.xxxxxxx, and it "failed to start".

    I've gone through the above recommended steps and still "failed to start".

    Please help !
     
  9. k662712

    k662712 New Member

    It's not working, considering the price of razer products, it's really frustrating to spend a couple of hundred dollars to get a keyboard that you couldn't make changes to. really disappointed.
     
  10. I also had this problem, and what solved it for me was to go in taskmanager and stop all razer services (including GameManagerService), and try start Synapse from startmeny again. I was asked it I would let synapse do some alterations and confirmed.

    A bit easier than Lauriats recipie
     
  11. GreenGinkgo

    GreenGinkgo New Member

    I believe I fixed this on my end, so it might work for you...

    I have:
    Windows 10 - latest updates
    Razer Naga Trinity mouse

    Issues: after a Windows update a few months back, Synapse 3 stopped launching. It would just hang in the tasks list but never show up graphically. Tried a fresh download from Razer's site over top of it, but no dice. The installer just sat stuck there with three dots pulsing forever. Here's what I did that ended up working...

    - Kill all Razer programs in the Task Manager - Ctrl-Shift-Esc -> Details tab - End Task on everything beginning with "razer" and also GameManagerService.exe
    - Stop all Razer services - Right click the Windows icon -> Computer Management -> Services and Applications -> Services -> Find everything named "Razer..." and right-click -> "Stop"
    - Remove the entire Razer directory - for me this was: C:\Program Files (x86)\Razer
    - Reboot
    - Install a fresh copy of Synapse 3 and Macro (I skipped other features like Chroma) - This was already an improvement, as the installer actually ran instead of being stuck!
    ---> The install finished and then I got a message that Synapse "Failed to start"
    - Since the install worked, I then went and Uninstalled everything using the right method - Windows settings -> Apps -> Uninstall from there
    - Reboot
    - At this point, NOTHING Razer should be left, however I found that the "Razer Central Service" was still present in the Services list mentioned earlier. I manually removed this by doing the following:
    ---> Close Computer Management window
    ---> Opened an Administrator Command Prompt - Windows menu -> Search for: "Command" -> Right click on "Command Prompt" and select "Run as Administrator" -> confirm the security warning - a black text window should appear
    ---> In that window, run this command to remove the Razer Central Service: sc delete RzActionSvc
    ---> This should result in a success message of some sort
    ---> Open up the Services list again just to confirm it's gone
    - Reboot
    - Install Synapse 3 again
    - SUCCESS!!!!


    I sincerely hope this helps you all out. There may have been unnecessary steps, but it did work out (for me) in the end.

    Good luck!
    ~Ginkgo
     
    Razer.Speedcr0ss likes this.
  12. leetcoastStizza378

    leetcoastStizza378 New Member

    I tried to reinstall Razer Synapse 2 or 3 many times. Problem with Razer Synapse 2 is that it does not support the new Razer BlackWidow 2019. But overall, reinstalling and giving programs administrative access, etc. did not work.

    After all, i tried reinstalling windows 10 and then installing Razer Synapse 3, and it works.

    Thanks.
     
  13. Silumi

    Silumi New Member

    I reinstalles Synapse 2 as well as 3 multiple times and it just doesn't work no matter how many steps I follow. I tried it with deleting the mouse itself as well with the wonderfull effect that it decided not to download the mouse tribers so yeah... the main Razer thing disappeared now as well. Honestly couldn't be more disappointed considering I just spend 80 Euro on a mouse that I can't even modify...
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >