Synapse not detecting the mouse

Discussion in 'Razer Support' started by ONYXMaroontech426, Jun 12, 2019.

  1. ONYXMaroontech426

    ONYXMaroontech426 New Member

    A friend just noticed that his Trinity is not listed as a Device after the Synapse 3.4.604.60316 update; the installer never finished and after 10 minutes the computer was rebooted. He has a Naga Trinity and after the update his synapse does not detect the mouse. The device detection may have failed months ago as he almost never changes his mouse setup and doesn't know if it was working just before the update. He has uninstalled, reinstalled, uninstalled, re-downloaded and reinstalled. He unplugged the mouse for various shutdowns and reboots and unplugged/replugged the mouse many times. The mouse is never detected by Synapse but does run in Win10 via the HID drivers. The mouse also still runs the button assignments and macros that were assigned before the update, i.e., is working but he can't change the keybinds or macros.
    Any ideas on how to force Synapse to detect the mouse? My update worked great.
    Happy Trails
     
    Last edited by a moderator: Jun 14, 2019 at 12:44 PM
  2. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Have your friend uninstall the HID drivers and run Windows Updater to get a device-specific driver. That should do the trick. Should you need further assistance, please don't hesitate to send me a PM.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >