Thunderbolt 3 / USB C problems (RBS 8550u)

Discussion in 'Systems' started by directImperialfever976, Jun 23, 2019.

  1. So after over a week of very delayed emails and live chats with Razer, I have decided to post my issue here to see if the community can help or at least expose an issue to Razer that they may or may not be ignoring.

    I have had my laptop for just under a year now, and since it arrived I have had some very peculiar issues with the USB C port.

    When using a USB C / Thunderbolt dock with a mouse / kb and charger plugged in, my peripherals lose power every few seconds for a couple of seconds making it impossible to use. If the charger is not plugged in, it is perfectly fine.

    Like I have said above, I have been speaking with Razer about this for a couple of weeks and their only answer was to buy a Razer Core..

    Below are the troubleshooting steps I have completed.

    - BIOS and Firmware updates
    - Windows Updates
    - System recovery of the device (through the Razer recovery partition)
    - Multiple docks (linked below)

    https://www.amazon.com.au/gp/product/B071YTQBXM/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1
    https://www.harveynorman.com.au/alogic-usb-c-portable-super-dock-with-power-delivery-black.html
    https://www.amazon.com/XtremeMac-Promate-Type-C-MicroSD-Ethernet/dp/B06X9LQ9ND
    ^^ These all had the same issue with the peripherals

    https://www.lenovo.com/au/en/access...s-usb/TP-Hybrid-USB-C-Dock- -ANZ/p/40AF0135AU (this one flat out didn't work at all)

    - A different 65W charger from a Lenovo device

    Now, this device has previously been sent off the Sydney (I live in Perth AUS) and took about a month to get back to me, the issue was not fixed even after the team in Sydney replaced the motherboard.


    On the RBS product pafe, they advertise the following about the Thunderbolt 3 port/

    "Meet Thunderbolt™ 3. It's twice as fast as
    Thunderbolt 2 and more versatile to boot.
    It connects to any display, port or peripheral
    device — allowing you to add more
    utility to your laptop with zero hassle"

    One would assume that this is false advertising as the Razer support team have told me the complete opposite about this statement (as shown at the bottom of this post)

    I have been advised against using third party docks as they won't work with the RBS (which I think is rubbish).

    Anyways, have a read of the chat history and if you have any issues with your blade, good look getting any decent support.


    Edit: Just realised I am unable to attach a txt file to the post for some reason so have just pasted the chat below.

    ---

    System Support (6/21/2019, 12:12:30 AM): Welcome to Razer Support, my name is Karen G. . Please hold for a few moments while I review your inquiry. For quality assurance purposes, you may be selected to receive a survey regarding your service experience.
    System Support (6/21/2019, 12:12:53 AM): Hi Ethan! How are you doing today?
    Me (6/21/2019, 12:13:09 AM): Hi Karen, was just speaking with someone before but something came up and I got disconneccted
    Me (6/21/2019, 12:13:17 AM): Not dong so great sorry Karen how about you?
    Me (6/21/2019, 12:13:59 AM): Doing *
    System Support (6/21/2019, 12:14:00 AM): I understand, let me make your day better by trying to resolve the issue you have with your Razer Blade. .
    System Support (6/21/2019, 12:14:43 AM): Let me check your case here. Kindly verify if the information below are correct:


    Name: Ethan Krause
    Email address:
    (taken out)
    Me (6/21/2019, 12:16:31 AM): Hi yep that's correct
    System Support (6/21/2019, 12:16:38 AM): Upon checking it seems that you are having issues with your USB-C dock that is creating conflict with your other peripheral devices. Correct?
    Me (6/21/2019, 12:17:52 AM): Yeah that's correct, your colleague mentioned that I'm not able to use any other docks apart from the Core and laptop stand with my laptop?
    Me (6/21/2019, 12:18:32 AM): This seems bizarre though because it is just a usb c / thunderbolt 3 port
    Me (6/21/2019, 12:19:00 AM): Are you able to see my previous chats? There is a fair bit of info in them
    System Support (6/21/2019, 12:19:17 AM): Yes, I was able to pull up your record.
    System Support (6/21/2019, 12:19:38 AM): Please keep your case number as a reference for this chat session. It's 03072404.
    Me (6/21/2019, 12:20:42 AM): Thank you
    System Support (6/21/2019, 12:20:54 AM): Yes, we do not recommend 3rd party USB-C docks since it may or may not work.
    Me (6/21/2019, 12:21:50 AM): So why doesn't it explicitly say this on checkout?? I have tried a couple of different Lenovo models with my docks and they worked fine, why is this not the case for a $2400 laptop?
    System Support (6/21/2019, 12:21:51 AM): Think of it like on a mobile device not all charger are compatible with iphone.
    Me (6/21/2019, 12:22:37 AM): Yes because iPhones only use thunderbolt.. I can connect my dock to my Samsung phone and use it with my mouse keyboard and charger
    Me (6/21/2019, 12:22:49 AM): Only use Lightning sorry **
    Me (6/21/2019, 12:24:00 AM): If I buy a device that says it is compatible with thunderbolt 3, then I should be able to use it right?
    System Support (6/21/2019, 12:24:34 AM): I totally understand.
    System Support (6/21/2019, 12:26:32 AM): Here's what I can recommend though, if you really want to use an external USB-C dock, try it on your laptop first before you purchasing one.
    System Support (6/21/2019, 12:27:18 AM): That's what I did with my Razer Blade.
    System Support (6/21/2019, 12:27:50 AM): It's a compatibility issue with some USB-C docks.
    Me (6/21/2019, 12:27:58 AM): This is not a usb c dock compatibility issue, you just advised that I shouldn't use a usb c / thunderbolt 3 dock, then you tell me you use one?
    Me (6/21/2019, 12:27:59 AM): https://www.razer.com/gaming-laptops/razer-blade-stealth-v4
    Me (6/21/2019, 12:28:13 AM): Right here it says that it has thunderbolt 3 allowing you to use it with anything that supports it
    Me (6/21/2019, 12:28:53 AM): I have tried one of the most popular third party docks that many other people are using with success without any luck
    System Support (6/21/2019, 12:33:15 AM): I understand, upon checking it seems that the previous tech asked you to perform a system recovery.
    Me (6/21/2019, 12:33:30 AM): Which I completed
    Me (6/21/2019, 12:33:34 AM): This also did not fix it
    System Support (6/21/2019, 12:36:50 AM): Alright, here's what I can recommend. Upon checking the case not only you are having issues with the third party dock but it seems that you are also experiencing issues with the charger that puts the laptop on sleep mode.
    Me (6/21/2019, 12:37:13 AM): At this point I am not happy with the product I have purchased, the website advertise that it will be compatible with Thunderbolt 3 devices, which it is not, so I spent $2400 on a laptop, when I could have gone to the shops and spent a grand less on a laptop that has a fully functional Thunderbolt 3 port. Can this please be escalated to someone higher or could you please provide me with a number I can call to speak with a manager
    Me (6/21/2019, 12:37:49 AM): I would rather my laptop not to be fixed, but replaced, with one that has a fully functioning thunderbolt 3 port as advertised on the product page.
    System Support (6/21/2019, 12:39:22 AM): Sure, as long as it is covered within warranty. May I know when and where did you purchase your laptop?
    Me (6/21/2019, 12:39:58 AM): I purchased it from the Razer online store on the 25th of July 2018
    Me (6/21/2019, 12:41:34 AM): If it gets replaced, will the port be fully functional as advertised? Because if not this route is not going to work
    System Support (6/21/2019, 12:42:08 AM): We have 14 days replacement and 1 year limited warranty.
    System Support (6/21/2019, 12:42:22 AM): Yes, the repair should fix the issue that you are having.
    Me (6/21/2019, 12:42:57 AM): Okay, you're not making sense now, you just told me that I can't use third party docks, but now you're telling me they can fix it??
    Me (6/21/2019, 12:43:19 AM): Can I please speak to someone higher up..
    System Support (6/21/2019, 12:43:38 AM): Sure.
    System Support (6/21/2019, 12:43:46 AM): Please give me a moment.
    System Support (6/21/2019, 12:44:02 AM): Let me transfer you to once of our higher level support.
    System Support (6/21/2019, 12:44:06 AM): Please stay online.
    Me (6/21/2019, 12:44:12 AM): Thank you
    System Support (6/21/2019, 12:44:29 AM): My pleasure.
    System Support (6/21/2019, 12:48:07 AM): Thank you for waiting.
    Me (6/21/2019, 12:48:31 AM): No worries
    System Support (6/21/2019, 12:48:38 AM): It seems that our higher level support are still engaged on a chat right now.
    Me (6/21/2019, 12:48:51 AM): Okay, I am happy to wait
    System Support (6/21/2019, 12:50:05 AM): Alright.
    System Support (6/21/2019, 12:50:12 AM): Please stay online.
    Me (6/21/2019, 12:50:28 AM): Will do, thank you
    System Support (6/21/2019, 12:50:36 AM): I will make sure to transfer once they are available.
    Me (6/21/2019, 12:50:40 AM): Thanks


    (this did get escalated, however, I did not hear from the escalation team for 2 and a half days)
     
  2. Joikansai

    Joikansai Well-Known Member VANGUARD

    It’s probably due incompatibility or bios setting that delivers inconsistent connection (not enough bandwidth/ over voltage protection) once it’s plugged on power delivery, since your stealth model TB3 act also as power delivery. I experienced DP and hdmi Crash using this usb c dock, didn’t take a look further like pheriperals connection stability due my main need was multiple monitor. So I bought Razer Core v2 which solved the issue.
    Similar pheriperals disconnecting issue on TB3 I saw as well on Blade 14 and 15 and user who reported success to solving it is by using Thunderbolt 3 dock from Lenovo (Docks you linked aren’t TB3 dock I believe), and caldigit TB3 dock), not quite sure if it’ll work fine for Stealth, maybe it’ll be worth to test.
    Probably it’s not enough test for cross brand docking station that enough for CS to recommend specific one, and hope Razer making also usb c/Thunderbolt dock since not everyone need gpu power from core and current stealth has dgpu option, which can give better support to Razer systems.
     
  3. Thanks heaps for the reply, I think you might be onto something re: TB3 docks. I thought the ones I bought were but it looks like they're not.
    I might go pick one up and test with it.
     
  4. Joikansai

    Joikansai Well-Known Member VANGUARD

    No biggies, hope it’ll work and keep us update, want to know also if it solve the issue.
     
  5. Interesting development, running an Ubuntu Live USB at the moment and having no issues at all, wondering if there is maybe an issue with the Windows image that the Razer Recovery uses.

    Going to try reinstall Windows from scratch, will update once complete.
     
    Joikansai likes this.
  6. Further to this.

    A fresh re install of Windows (not using the Razer recovery image) has fixed a lot of my smaller issues including
    - Not shutting down correctly (taking a few minutes to actually power off)
    - Hibernating when plugged into charge
    - Overall speed and performance of the device even compared to the Razer recover I did a couple of days ago

    Unfortunately this has not fixed the USB C hub issue, however, I am going to keep looking into this as it did work fine on Ubuntu.

    Will update once I know more.
     
    ivan.cutchon likes this.
  7. Tone4k

    Tone4k New Member

    I've now had the USB-C port die twice. Seems to happen when I have a drive plugged in and the drive getting disconnected without it being properly ejected.
    The first time it happened, I got on Razers online live chat support and they told me to reinstall the thunderbolt driver which is found on the Razer website. That didn't fix the problem.
    I fixed the issue the first time by re installing the Razer Intel chipset firmware.
    Today, the same thing has just happened again. It's not just the drive that wasn't ejected that doesn't work, the whole port gets immobilised. Power runs to it, but no usbc device with work.
    I rely on my Razer for data management and this is a major flaw. Surely I don't have to keep reloading firmware just to get a port to work.
    What's the issue Razer?
    Love my Razer Blade 15 Base, but this issue is really unacceptable. Any chance it can be fixed permanently somehow?
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >