THX Not Working on Kraken TE/Can't Calibrate Surround

Discussion in 'Razer Support' started by SuperMaki, Jan 4, 2019.

Thread Status:
Not open for further replies.
  1. SuperMaki

    SuperMaki New Member

    So, for some reason, I can't even use THX at all. I press the button over and over, and the LED THX indicator just never lights up. The headset works fine, mic works fine, every other button on the control box works, just not the THX button. For absolutely zero reason. I seem to be the only one with this issue, I have searched up and down. Also, I can't use Synapse 3 for the headset since Synapse 3 is bugged and never opens on my PC.

    I can't calibrate Razer Surround Pro on Synapse 2.0. I can only hear anything if I have "Headset Earphone Razer Kraken TE - Chat" set as my default playback device. But if I set that as my default device, it automatically turns off Razer Surround. Also, within Razer Surround Pro, I can't select my headset for the Audio Interface. I only have the option between Realtek Digital Output & Realtek High Definition Audio. On top of all this, the Razer Kraken TE doesn't show on the optimization list. What is going wrong? Why is there always so many finicky issues with Razer..

    EDIT: So, I got the surround sound(probably only 5.1) working on Razer Surround Pro without having to set "Headset Earphone Razer Kraken TE - Chat" as default & I can hear everything, but ONLY when I plug the headset into a 3.5mm jack (I hear absolutely nothing if I plug in the USB box). If I used my headset this way, the mic doesn't work. I'm literally trading out mic accessibility, bass boost, THX, game/chat audio toggle just to be able to hear some basic (maybe) 5.1 surround sound. What's the point of the THX box if it doesn't work? -slowclap-
     
    Last edited: Jan 4, 2019
  2. rarestofpepes

    rarestofpepes New Member

    Have you tried doing a clean install? These are the steps I got from Razer support. I'm having trouble getting THX to work as well. The headphones work fine, but THX and EQ don't work for me. Unfortunately, it didn't work for me, but it could for you. I might be doing something wrong. Here you go and good luck:


    CLEAN INSTALL SYNAPSE


    To uninstall:



    1. Uninstall "Razer Synapse" and "Razer Chroma SDK Core Components" from your computer under Program and Features.



    2. Delete all files in C:\Program Files (x86)\Razer\Synapse and C:\ProgramData\Razer\Synapse directories. These folders are hidden by default, so please be sure to unhide them by accessing "Folder Options", then, go to the "View" tab and select "Show hidden files, folders, and drives."



    Note: If you are somehow unable to delete these folders, you may have to kill any Razer Synapse related processes running in your task manager.



    3. To ensure that there are no residual files remaining that may corrupt the installation, restart your computer.



    4. Go into device manager, go to Keyboards and Audio inputs and outputs 0 mouse and other pointing devices, uninstall HID Keyboard and Mouse Drivers and all other Razer product drivers, and restart your PC. Be sure to select delete drivers as well when uninstalling.





    Delete all Razer files in the computer:



    1. Press Windows + r, and type CMD and press enter

    2. Type regedit in the command prompt window and press enter.

    3. Please go to this path and delete it. Please remove this registry key:

    HKEY_LOCAL_MACHINE\SOFTWARE\WOW643NODE\Razer

    4. If Razer Chroma SDK is available, please delete it also.

    5. Restart your computer again.

    6. Temporarily turn off all Firewall and Antivirus software to prevent any conflicts.



    7. Make sure you have the latest version of Microsoft .NET framework (4.5 or higher). You may download them at http://www.microsoft.com/en-us/download/details.aspx?id=30653.





    To re-install Synapse:



    1. Click on the link below to download Synapse 3 software



    https://bit.ly/2u11eB7



    2. Download and save installer.

    3. Once the download has completed, run the file as Administrator and install the application. Just follow on-screen instructions. The installer will guide you through the process.

    4. Once the installation is complete, log in to your Razer ID account.

    5. Make sure that install all module -- macro, chroma, and hue.

    6. Check if clean install resolves the issue.
     
  3. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member


    Hi there! Are you still having the issue? If so, have you tried to plug it into a different PC to see if the same issue persists? If not yet, please do and let me know how it goes.
     
  4. rarestofpepes

    rarestofpepes New Member

    I tried with mine and the EQ and THX both worked on a different PC. I emailed support with my a log file that I created and I'm currently waiting on a response. I believe there's a software problem on my main PC. I want to say I think I did everything right that I was told to do from what support has been telling me to do in the email correspondence.
     
  5. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member


    Hello! Can you PM me the case number? I'd like to take a look.
     
    Last edited: Jan 23, 2019
  6. Kazauwa

    Kazauwa New Member

    Did you find a solution? I'm struggling with the same problem: either I have a THX sound and no mic or vice versa. I found out that THX only works when using "Razer Kraken TE - Game" and mic works only in "Razer Kraken TE - Chat". Obviously, I can't use both simultaneously. I've tried everything I could ever think of, including clean reinstall described above.
     
  7. rarestofpepes

    rarestofpepes New Member

    Not yet. I'm currently working with support to find a solution. They've been doing a excellent job with helping me out. My THX doesn't work at all. I don't use my mic so I have no idea if it works or not. Hopefully you find a solution so. Keeps us informed if you find a solution and I'll do the same.
     
  8. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hi there, please set the following in the Playback tab:

    Kraken TE - Game as the default device
    Kraken TE - Chat as the default communications device

    If you have any more questions, please send me a PM. Make sure to include the link to this thread.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >