THX Spatial stopped working, then Razer Nari won't show up on dashboard, then pairing util. issues

Discussion in 'Razer Support' started by WomTon, Jun 9, 2021.

Thread Status:
Not open for further replies.
  1. WomTon

    WomTon New Member

    This has been a rather frustrating day. My THX Spatial sound wasn't coming through (this is a common issue unfortunately). I tried some troubleshooting options and it came to a point where I tried reinstalling Synapse 3. After that happened, my Razer Nari Ultimate wouldn't show up on my dashboard. Because of that, I tried removing the dongle from my PC and then placing it back again, hoping synapse would reinstall that way. Instead, synapse was just completely removed and then didn't reinstall. I then tried reinstalling again along with the pairing utility for Razer Nari Ultimate. The pairing utility ended up not working as the pairing would always fail for some reason. both the dongle and the headset are the same version (they came in the same box) and I'm really frustrated since I payed a good $220 for this thing including tax.

    Edit:
    I am also slightly confident this happened after I updated all the drivers on my computer including the razer audio drivers.
     
    Last edited by a moderator: Jun 10, 2021
  2. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    There is a good chance that the headset is not properly detected if even the pairing utility fails to recognize the device. Please send me a screenshot of how the headset appears on the Device Manager, along with the serial number. Let's go from there.

    *Thread locked to curb the conversation to PMs.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >