Ubuntu on 2022 Razer Blade 14'' with 3070 Ti

Discussion in 'Razer Support' started by surveily, Jun 1, 2022.

  1. surveily

    surveily New Member

    I've recently bought the new [2022 Razer Blade 14'' with 3070 Ti](https://mysupport.razer.com/app/answers/detail/a_id/5924/~/at-a-glance:-razer-blade-14-(2022)-|-rz09-0427x).

    Unfortunately after installing Ubuntu 22.04 Desktop I've quickly come to realize that neither WiFi nor BT are working.

    Information below:

    ```
    uname -a
    Linux surveily-wt-04 5.18.0-051800-generic #202205222030 SMP PREEMPT_DYNAMIC Sun May 22 20:33:46 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

    ```

    ```
    sudo lspci -vqk -s 02:00
    02:00.0 Network controller: Qualcomm Atheros QCNFA765 (rev 01)
    Subsystem: Lite-On Communications Inc Device a82d
    Flags: bus master, fast devsel, latency 0, IRQ 106, IOMMU group 13
    Memory at fc200000 (64-bit, non-prefetchable) [size=2M]
    Capabilities: [40] Power Management version 3
    Capabilities: [50] MSI: Enable+ Count=32/32 Maskable+ 64bit-
    Capabilities: [70] Express Endpoint, MSI 00
    Capabilities: [100] Advanced Error Reporting
    Capabilities: [148] Secondary PCI Express
    Capabilities: [158] Transaction Processing Hints
    Capabilities: [1e4] Latency Tolerance Reporting
    Capabilities: [1ec] L1 PM Substates
    Kernel driver in use: ath11k_pci
    Kernel modules: ath11k_pci

    ```
    ```
    sudo dmesg | grep ath
    [ 0.000000] Linux version 5.18.0-051800-generic (kernel@kathleen) (gcc (Ubuntu 11.3.0-3ubuntu1) 11.3.0, GNU ld (GNU Binutils for Ubuntu) 2.38) #202205222030 SMP PREEMPT_DYNAMIC Sun May 22 20:33:46 UTC 2022
    [ 2.287214] ath11k_pci 0000:02:00.0: BAR 0: assigned [mem 0xfc200000-0xfc3fffff 64bit]
    [ 2.287231] ath11k_pci 0000:02:00.0: enabling device (0000 -> 0002)
    [ 2.287642] ath11k_pci 0000:02:00.0: MSI vectors: 32
    [ 2.287658] ath11k_pci 0000:02:00.0: wcn6855 hw2.1
    [ 3.459225] ath11k_pci 0000:02:00.0: chip_id 0x12 chip_family 0xb board_id 0xff soc_id 0x400c1211
    [ 3.459229] ath11k_pci 0000:02:00.0: fw_version 0x110d8c35 fw_build_timestamp 2022-01-27 04:01 fw_build_id QC_IMAGE_VERSION_STRING=WLAN.HSP.1.1-03125-QCAHSPSWPL_V1_V2_SILICONZ_LITE-3
    [ 3.466553] ath11k_pci 0000:02:00.0: failed to fetch board data for bus=pci,vendor=17cb,device=1103,subsystem-vendor=11ad,subsystem-device=a82d,qmi-chip-id=18,qmi-board-id=255 from ath11k/WCN6855/hw2.1/board-2.bin
    [ 3.466588] ath11k_pci 0000:02:00.0: failed to fetch board-2.bin or board.bin from WCN6855/hw2.1
    [ 3.466599] ath11k_pci 0000:02:00.0: qmi failed to fetch board file: -2
    [ 3.466599] ath11k_pci 0000:02:00.0: failed to load board data file: -2

    ```

    Can anyone help me with resolving this issue?

    Edit: I tried Ubuntu 18.x, 20.x, 21.x, 22.x and fedora 36 with all various kernels and it all shows the same errors. Looks like only Windows has the drivers for the recent hardware.

    Edit: I tried copying the drivers from https://github.com/kvalo/ath11k-firmware but its for WCN6855 and not the WCN6856 in my Blade 14''.
     
    Last edited: Jun 2, 2022
  2. surveily

    surveily New Member

  3. Facing same issue, also tried many OS versions (deb based), so success.
    Just got new laptop, and it was really unexpected to face that kind of issue.
    As i understood no official reply from Razer yet?
    I thought Lenovo support was bad...:big_grin_:
     
  4. surveily

    surveily New Member

  5. surveily

    surveily New Member

    Yes, don't know how to fix.
     
  6. surveily

    surveily New Member

  7. surveily

    surveily New Member

  8. bluetooth fix through dkms is here:
    https://github.com/wimvanboven/razer-blade-14-2022-btusb

    NB: before i updated the EC firmware, the bt device sometimes failed to be enabled at boot. problem hasn't reoccurred after EC firmware update, so best to do this upfront as it needs windows.

    i've been fighting the mic for a few days now. but i guess something is messed up with the alc897 codec config and the bios probably does not report the pin config properly.
    messing with the pins through hdajackretask utility did not yet lead to success. i think the built in mic is on pin 0x18, but when i toggle it and unmute it in alsamixer, no sound is recorded.
     
  9. small update on the microphone stuff, i have had no luck with the built in mic, but i did manage to get the mic running on earphones with jack.
    they seem to be on pin 0x19, but i had to disable the jack detect setting. i used the 'hdajackretask' tool to remap the pin. it saves a file to /lib/firmware and applies the patch via module option (if you see multiple values, that is because the blade has multiple devices using snd_hda_intel, the 3rd one is the realtek, the first 2 in my case are HDMI.
    with jack detection enabled, it doesnt work, the pin is never discovered as connected. with it disabled, you will see the input device always, even when unplugged.
    going to keep messing about :)

    $ cat /lib/firmware/hda-jack-retask.fw
    [codec]
    0x10ec0897 0x1a58201c 0

    [pincfg]
    0x11 0x40000000
    0x12 0x40000000
    0x14 0x90170110
    0x15 0x411111f0
    0x16 0x411111f0
    0x17 0x411111f0
    0x18 0x411111f0
    0x19 0x03a11130
    0x1a 0x411111f0
    0x1b 0x03211020
    0x1c 0x411111f0
    0x1d 0x4026892d
    0x1e 0x411111f0
    0x1f 0x411111f0

    $ cat /etc/modprobe.d/hda-jack-retask.conf
    # This file was added by the program 'hda-jack-retask'.
    # If you want to revert the changes made by this program, you can simply erase this file and reboot your computer.
    options snd-hda-intel patch=hda-jack-retask.fw,hda-jack-retask.fw,hda-jack-retask.fw,hda-jack-retask.fw


    upload_2022-8-13_10-9-26.png
     
  10. i doubt it will, as SOF does not have support for AMD yellow carp/rembrandt yet in the mainline. it seems to be on the roadmap, but i dont expect so see it before kernel 6.x.x
    you can actually see in the journal no sof firmware is loaded.

    the 'non sof' audio coprocessor driver for AMD YC is loaded instead (acp6x). but how this all connects to the codec is a mystery to me. just for funs, i tried out kernel 6rc1 as it contains a huge bunch of updates to acp6x, but nothing changed. anyway, it seems both this driver and the sof one are still under active development. so hope it will sort itself out in upcoming kernels :) fingers crossed
     
  11. technoRubyguide592

    technoRubyguide592 New Member

    Cool regarding the plugged in mic, I'll try that.

    This new digital mic stuff is messing up everything (since it seems linux support is not great -- makes sense because it seems it was made for microsoft cortana or something...?)!

    Bummer, as linux support was getting better and better over the last few years, even for new hardware. And now they had to go and make these new fangled microphones and s2 sleep mode and break a bunch of things that work. But, I guess I say that every 5 years or so when there is a jump in technology haha.

    I've come to pretty much the same conclusion regarding microphone (you linked this in comments there). https://www.reddit.com/r/razer/comments/whm0oz/gnulinux_kubuntu_2204_on_razer_blade_14_2022/

    I also bought an ASUS system with a different sound card, and it seems that even for that I need to wait for kernel 6.0 for it to work (in that case, speakers don't work but mic in does haha).
     
  12. surveily

    surveily New Member

    Kernel 6.0 is available from mainline. Anyone tried it yet?
     
  13. surveily

    surveily New Member

    Kernel 6.0 didn't change anything for me
     
  14. surveily

    surveily New Member

    Kernel 6.0 fixes the bluetooth :)
     
  15. the wifi firmware has also been added to the mainline firmware repo. should arrive soonish on your distro of choice.
     
  16. surveily

    surveily New Member

    No nvidia-driver support tho
     
  17. surveily

    surveily New Member

    I've installed the supposedly 6.0-compatible nvidia-driver from their PPA - no luck. It stopped working after 2nd reboot.

    Unfortunately the BT doesn't work either. I must have booted to windows first so it got turned on before switching to Ubuntu 22.04.1.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >