Unable to update firmware for Razer BlackShark V2 Pro

Discussion in 'Razer Support' started by Felburn, Dec 23, 2021.

Thread Status:
Not open for further replies.
  1. Felburn

    Felburn New Member

    I open the updater, plug in dongle which takes me to step 2: plug in the headset with the cable that it came with. Which I do and I see it charging, but the "NEXT" button is unclickable. Iv tried doing it with and without razor synapse and disabled all firewalls.
     
  2. Razer.Xenon

    Razer.Xenon Retired

    Does your headset still get detected on your Device Manager? For now, let's uninstall your headset drivers by doing the following:
    -Press Windows + S on your keyboard to open the Search bar.
    -Type in “Device Manager” and hit Enter.
    -Go to Audio Inputs and Outputs.
    -Right-click on your Razer headset and select Uninstall device.
    -To completely uninstall the drivers, restart your computer.
    The drivers are automatically installed on your computer after a restart. Should the issue persists, PM me the serial number of your device along with a screenshot of the error when trying to update its firmware. I can use those to take a closer look at the situation and find other possible solutions.

    *Thread locked to curb the conversation to PMs.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >