Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

USB boot no longer responding - BIOS seems stuck

Discussion in 'Systems' started by bestONYXBlueSapphire055, Jan 15, 2019.

Thread Status:
Not open for further replies.
  1. I recently installed Fedora 29 on my RBS 2017. This worked just fine. I was able to use an external SD Card to boot using their linux live iso. No issues once I tweaked a few Bios settings. Now I want to go back to Windows 10 and have created a USB (using the same setup) and it wont even recognize the SD card anymore. Not sure what setting I have jacked up in the BIOS but after resetting to defaults, I still cant get a single USB to show up as anything but generic UEFI device. Once I select it it just returns immediately to the boot menu. I think I have just messed up something with the BIOS config but I think I have tried every combination at this point of set up.

    I have already tried the following:
    USB Legacy Enabled, Secure Boot Off
    CSM Enabled with UEFI on for all Policies
    CSM Enabled with Legacy for all Policies
    CSM Disabled

    I am at a point where I am thinking I just need to pull the battery out and try to manually reset the bios.

    The whole reason I got here was in trying to get a Thunderbolt 3 eGPU working in linux with a Sonnet Breakaway Box (RX580). The RBS doesn't really work correctly with the eGPU case. The box just keeps resetting or powering on / off. I was heading back to Win10 to run all of the Razer firmware updates. My plan was just reset to a dual boot mode with a smallish Windows partition and Fedora 29 on the remainder.
     
    0V3R_K1LL likes this.
  2. Joikansai

    Joikansai Well-Known Member VANGUARD

    Hi there, wellcome to Insider :)
    How much power adapter that comes with your stealth and is your box capable to deliver that wattage? When I’m not wrong sonet box has different model options.
    You may want also to look at systems Linux corner here.
     
  3. Thanks - the sonnet is putting out 60W. That said, I am not sure it is reliable or running the latest controller firmware. It works perfectly fine with a 2017 13' Macbook Pro. At this point solving that problem has become secondary to fixing the BIOS support of USB boot images.
     
  4. Joikansai

    Joikansai Well-Known Member VANGUARD

    I’m not sure about Linux egpu setting, but maybe it’ll be better rising technical support or asking original usb recovery to resetting your Blade stealth to factory form (without it you can access it as well by pressing F9 after booting), it’ll take a lot work since you’ve to restoring and setting your stealth,
    About egpu setting, it sounds to me the enclosure couldn’t deliver demanded wattage from Stealth or there’re traffic jam in bandwidth concentrating for power delivery and data transfer. On dual core MacBook Pro, the power adapter is 60 watt, right? So your sonet box can deliver the power, but your stealth 2017, if it is with quad core, it will demand more power, quad core i think 65 Watt ac adapter. On older models like 2016 dual cores with 45 watt ac adapter it should be no problem for the box to charge it.
     
  5. I think I figured it out. It was an issue with how OSX is partitioning the USB images. There must be a bug in the latest beta of OSX that is causing the partitions to be non bootable. I ended up doing it manually using diskutil and I was able to make it work. After this I had to create all kinds of crazy bootable ISOs with Fat / ExFat partitions to get a valid install USB created. Then screw around with windows only wanting to install W10 from the actual hard disk in a partition that was GPT vs MBR. All of this to update a firmware! I suppose I brought it on myself. Thanks for the input.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >