Huntsman V2 Analog some keys suddenly stopped working | Razer Insider
Question

Huntsman V2 Analog some keys suddenly stopped working

  • 23 October 2023
  • 2 replies
  • 263 views

 

Keyboard has been working perfectly normal, but today I got home, turned on my pc and saw that I couldn't enter my password, so I re-plugged the kb, but it still wasn't working, so I used the on-screen keyboard to log in and the keyboard started working as soon as synapse loaded. I didn't give it much thought but then realized that both square brackets aren't working. I went to check all keys on that kbtester site and found out more not functioning keys (picture below shows all not functioning keys). I checked synapse and saw a hyperlink for a firmware update, installed it, thought that would fix it, but it didn't.

I already tried restarting synapse and my pc, unplugging and plugging kb back, updating firmware, checked for synapse and windows updates and creating a new keyboard profile in synapse, clean synapse reinstall, used SFC and DISM, hard resetting kb (a couple of times), connecting to another PC. None of that did the job…

The keyboard hasn’t moved an inch since I used it yesterday and turned off my pc, so I’m thinking that there is nothing wrong with the hardware. It’s most likely an issue with it’s firmware. Can I please get assistance with

Can I please get some assistance for fixing this. I’ve been sitting here for 3 hours now trying to fix it and it’s getting pretty frustrating.

 


2 Replies

Hi

I just purchased a brand new Razer Huntsman V2 Analog.

The Keys “H” an “Q” weren’t working. I updated the firmware to 1.6 r2.

Now “H” is working but “Q” doesn’t.

Tried everything like resetting, delete all the profiles an macros running the keyboard without Synapse, other USB port - nothing helps.

@Defr1cti0n have you solved your problem?

That’s exactly the same combination of keys that don’t work on my Huntsman 2 keyboard.  @Defr1cti0n did you ever solve or get an answer?

 

Reply