[SUPPORT VIDEO] Fix Flickering/Stuttering Lighting Effects On Keyboard | Razer Insider
Sticky

[SUPPORT VIDEO] Fix Flickering/Stuttering Lighting Effects On Keyboard

  • 22 December 2021
  • 34 replies
  • 7942 views

Userlevel 7


Flickering or stuttering of lighting effects on your Razer keyboard can be caused by connection or firmware issues. This video will show you how to fix stuttering or intermittent flickering of lighting effects on your Razer keyboard.

Please note that any damages caused by upgrading or modifying your Razer product are not covered by Razer's Warranty Policy. For more information, see Razer's Warranty Policy.

Visit the Support pages regarding: Software and Firmware Updates for Razer Peripherals and How to perform a clean re-installation of Razer Synapse 3 & 2.0 on Windows

- - -

Insiders, what do you think the next Support video should be? Comment with a topic. Great suggestions will be rewarded with the repeatable "Nice" achievement.

Also, for every 20 comments on this thread and the YouTube video, I'll be giving away a random "Great" Achievement. Insiders, be sure to leave your Insider ID in the YouTube comment to be eligible.

Lastly, for those of you who subscribe to the Support channel, we'll be doing massive Silver giveaways for each milestone, so be sure to tell your friends, smash that like button and subscribe to the channel.

This topic has been closed for comments

34 Replies

Userlevel 7
Awesome topic. I can see myself having this problem.
It never happened to me but i am sure if it happened i'd be pretty annoyed.
Userlevel 7
Will there be a video of how to solve problems with the laggy volume wheel on BlackWidows and others? The fact it likes to do whatever it wants is a bit frustrating about a 200 EUR keyboard
Userlevel 7
couldn't imagine this could happen. Great guide Razer!
Userlevel 7
Another great video. 🍀
Awesome video, I appreciate it! I think more fan-friendly videos would be helpful in expanding the channel's audience - videos explaining some key features of Cortex PC, detailed instructions on the many ways to earn Silver, etc!
As usual, great support video. Never experienced this problem myself. But those who had, would finally be able to solve it.

Thanks Razer 🙂
Userlevel 7
Thanks for the info
Userlevel 7
It happens to my Ornata v2 when my pc were off
Userlevel 7
Nice video
Userlevel 7
nice guide even though this hasn't happen to me yet.

using Razer BlackWidow X Tournament Edition Chroma since 2017, claim it with Razer Silver.
Userlevel 7
Badge +1
Nice guide.
I've had an issue, when GPU drivers were causing similar issue. After updating it, the problem dissapeared.
Userlevel 7
Very useful video ! Thank you and keep it up RAZER !
Userlevel 7
Hello friends,

Thanks Razer Support for this new tutorial.

Merry Christmas. 🎄🎅
Userlevel 7
Luckily I've never had this problem but if anyone does I hope this can fix it 🙂
Userlevel 7
Good job on this one!
nice
Userlevel 7
Nice Guide!!!
Userlevel 7
I had flickering happening on the original Firefly, updated the firmware and it fixed it. Also had some RBG problems with the Blackwidow V2 but firmware update fixed that too.
I did not have this problem but my lights wort working it turns out I am just the dumbest person alive and I had tured the brightness all the way down there is nothing round with my keyboard lol but I have to say the support team is amazing they trouble shotted with me answered every single thing I asked and was super nice can anyone tell me if there is a way for me to send a good review?
Userlevel 7
touch wood... but happy to say i've not encountered this with either of my Hunstmans.
when it comes to software (and hardware) - update early and often my friends
Userlevel 7
Some basic troubleshooting, nothing fancy. But what happens when you try all of the above and nothing works?
another helpful support video, good job razer
Great Guide Insiders.
Userlevel 7
ARMOR_152
I had flickering happening on the original Firefly, updated the firmware and it fixed it. Also had some RBG problems with the Blackwidow V2 but firmware update fixed that too.

Glad to hear it all works now 🙂