Basilisk X Hyperspeed Bluetooth stopped working. Started showing as Dfubasilisk. | Razer Insider
Question

Basilisk X Hyperspeed Bluetooth stopped working. Started showing as Dfubasilisk.

  • 20 February 2024
  • 4 replies
  • 54 views

I have a Basilisk X Hyperspeed and it suddenly stopped working.

My notebook (Macbook Pro M1 2022) is not finding the mouse on the bluetooth connections, even though i have reseted the mouse. If i try to connect to a Windows PC, it show 'Dfubasilisk', and it connects to the device, but the mouse does not work. It's like the mouse firmware is not working anymore.

I've seen some people had the same issue, but couldn't find anyone that has solved it. 

Does anyone knows the solution for this problem?

Thanks in advance.


4 Replies

Userlevel 7
Badge +1

It looks like it’s in stucked in bootloader mode. On Windows I’d try to download firmware and try to update it: https://mysupport.razer.com/app/answers/detail/a_id/4553

 

Thanks for the answer, @FiszPL!

I tried updating the firmware, but when i connect the mouse using the dongle, the updater says my mouse has the latest firmware and it still cannot find the mouse on bluetooth (it only shows as 'Dfubasilisk'), so it doesn't try to update bluetooth firmware.

 

Do you know if there is a way to reset the mouse to factory/default settings? 

Thanks again!

Userlevel 7
Badge +1

If you się dfubasilisk on bluetooth Connect to it and do fw update.

@FiszPL I tried to, but the firmware updater does not recognizes the mouse. I'll try again and see it works.

Is there any way to force the update? 

Reply