Deathadder V2 Pro mouse - bluetooth mode not working | Razer Insider
Question

Deathadder V2 Pro mouse - bluetooth mode not working

  • 10 April 2023
  • 8 replies
  • 1677 views

Same symptoms as this post: Deathadder V2 Pro mouse - bluetooth stopped working | Razer Insider 

Bluetooth mode on my mouse suddenly stopped working! I use 2.4 for my PC and bluetooth for my Mac. 2.4 mode is working just fine. 

When I switch the mouse to bluetooth mode, the Razer logo light never turns on. Triggering the pairing mode (how-to here) does not work. The Razer logo does not blink, and never turns on at all when in bluetooth mode or trying to pair. 

Attempts to fix: 

  • On my Mac I have removed the razer mouse device. 
  • Charging the mouse to full battery
  • Updating the firmware 
  • licking the razer logo (not bad, but recommend cleaning before and after). 

Thanks


8 Replies

Hello, i have the same problem with my mouse, but in 2.4ghz mode. I think its a mouse defect its not a software problem. Warranty support needs to be contacted i guess :)

The error is due to the mode switch! I don't have a 2.4Ghz signal until I start to press the switch slightly towards the "off" position with one finger. so as long as I hold the position with my finger, the mode also works. If I take my finger away again, the mouse immediately loses the connection. I was able to test the problem on all 5 mice and had the same results everywhere.
my guess is that the contacts are not 100% solid and are not 100% where they should be and after a very short use or even the first use, the function is restricted or completely broken

 

 

Ah you’re completely right! My bluetooth stopped working as well on my DeathAdder V2 Pro, but if I switch the toggle slightly then it activates. This is horrible 😅. Thanks! I’ll contact razer to get this one sorted🤞

I have exactly the same problem.

I had already one mouse replaced by warranty, and now problem appeared one year later.  Looks like design fault?

When I switch that little switch on the bottom between 2.4 GHz and Bluetooth mode, in BT mode the little dot LED is off, the logo LED is off, looks like mouse is not powered. 3 button reset combination doesn;t work too, nothing happens.

 

Yeah, I got mine replaced brand new. It'll probably happen again at some point 🙃

Same issue here. My Deathadder V2 Pro is DEAD under Bluetooth mode. None of the lights are on when switching to Bluetooth.

Yep, the problem is the switch...I have the same problem with the bluetooth. So far the 2.4 is working fine, so I keep the switch on that position….A shame...the switch seems to be defective...

I am also having this problem. The bluetooth isn't working at all and that makes it unsuable for me since mac does not have an USB-A port for the doodle.

Hopefully the support shall be able to help me, because this mice does not even have half an year of usage 😔

Reply