razer deathadder v3 pro firmware problem update | Razer Insider
Question

razer deathadder v3 pro firmware problem update

  • 8 November 2023
  • 11 replies
  • 677 views

Userlevel 1

Hello, I have a problem with the mouse Razer DeathAdder V3 Pro, I can not update the firmware v2.00.03_r1, the dongle is updated, but the mouse is not updated, gives an error, what to do? 

 


11 Replies

SAME PROBLEM TO ME

Userlevel 5

When I went to update my Viper V2 Pro and Cobra Pro to the Version 2.0 Firmware I made sure the USB Cable AND Dongle were plugged into the host computer first. Then I chose the left option first in the updater window which does the dongle mode update, then it proceeds with the wired mode firmware update after that, no issues here… maybe try this? I had both mice updated within 5min or less without any issues 😀

BRO THIS HAPPINGING TO ME TO, I was doing everything correctly, And everything was going fine, It said I updated my dongle, So I went to update my mouse but then my left click stopped working, then I reset my pc and it fixed itself, But when I went back to update, When I pressed Update my mouse kept disconnecting and reconnecting for no reason and I can’t update. 😭 They need a way to reset the firmware to it’s original state.

Yeap same here, i updated the dongle and now I can’’t update the mouse, this is such bs pleasee helpp

 

This is also happening to me. Now I can’t use the mouse wireless at all and need to keep it wired, which is pretty inconvenient. I tried uninstalling Synapse, rebooting, running the firmware updater to update the mouse only and nothing. Installed the latest version of Synapse after and again, same issue.

 

This isn’t good.

I managed to find a fix idk how it worked but when I clicked on the update button I unplugged the mouse with the ubs-c cable, the update itself it was stuck at 0% and after 1 minute it said for me to reconnect the mouse, I did that and the update continued wtf, the I paired my mouse with the dongle again because it was unpaired since I tried to many things and also on the pairing I moved my mouse and clicked on it untill it paired, hope it works for someone else aswell 

I managed to find a fix idk how it worked but when I clicked on the update button I unplugged the mouse with the ubs-c cable, the update itself it was stuck at 0% and after 1 minute it said for me to reconnect the mouse, I did that and the update continued wtf, the I paired my mouse with the dongle again because it was unpaired since I tried to many things and also on the pairing I moved my mouse and clicked on it untill it paired, hope it works for someone else aswell 

Wow, this actually worked! Thank you so much!

THANKS WORK FOR ME

I managed to find a fix idk how it worked but when I clicked on the update button I unplugged the mouse with the ubs-c cable, the update itself it was stuck at 0% and after 1 minute it said for me to reconnect the mouse, I did that and the update continued wtf, the I paired my mouse with the dongle again because it was unpaired since I tried to many things and also on the pairing I moved my mouse and clicked on it untill it paired, hope it works for someone else aswell 

no way it actually worked. it usually kept disconnecting on its own and saying “The update is not able to proceed because Synapse or some other application is running” every time i attempted to update. After unplugging manually and replugging right after the messagebox saying to reconnect the device again i had to press update once more and then it worked.

a huge big THANK YOU !!! i went crazy with this update until ure “fix” idea or whatever but yea it really worked!!!! you saved the day and razer…. FIX URE “STUFF” ! 

I managed to find a fix idk how it worked but when I clicked on the update button I unplugged the mouse with the ubs-c cable, the update itself it was stuck at 0% and after 1 minute it said for me to reconnect the mouse, I did that and the update continued wtf, the I paired my mouse with the dongle again because it was unpaired since I tried to many things and also on the pairing I moved my mouse and clicked on it untill it paired, hope it works for someone else aswell 


I would like to add something. I kind of did the same thing except I had to use a second mouse. When I kept getting the “synapse is open” message I unplugged and turned off my mouse. BUT I had to be VERY careful not to let the mouse sensor touch anything while it was asleep before I plugged it back in. If you set the mouse down and plugged it in, it registered for me that synapse was open. So i turned my mouse upside down not to touch my mousepad, which is where the second mouse came in. I used the second mouse to click “update” while I plugged it in while asleep and voila, it finally took

Reply