Cortex rewards not working after update? | Razer Insider

Cortex rewards not working after update?


When I open it I just get a white background with black text saying "Error". Anyone else?

This topic has been closed for comments

9 Replies

Hi guys, we were doing some server maintenance earlier. Sorry for the error. But it's back to normal now.

So start gaming!
AlphaTay
hi, where is the claim now button, i can't see it, i tried multiple times. thx in adv.

After you earn your points you have to claim them in Cortex.
Yes I am having same issue. I have even uninstalled and then reinstalled.
Userlevel 7
Badge
crazy1701d
Yes I am having same issue. I have even uninstalled and then reinstalled.

PhrostByt
When I open it I just get a white background with black text saying "Error". Anyone else?

Should be fixed by now. Please try again.
Mine is working fine now. Thanks
It's working fine now but apparently they added a requirement to click "Claim" now to get your points. Completely unnecessary change... it was perfectly fine before.
Userlevel 7
PhrostByt
It's working fine now but apparently they added a requirement to click "Claim" now to get your points. Completely unnecessary change... it was perfectly fine before.

hi, where is the claim now button, i can't see it, i tried multiple times. thx in adv.
Userlevel 7
Badge
PhrostByt
When I open it I just get a white background with black text saying "Error". Anyone else?

I noticed the error before and after update as well. Will be informed someone to check on it as well.
Userlevel 7
PhrostByt
After you earn your points you have to claim them in Cortex.

hi, the problem is, the whole interface is same as before, without any claim button. i just updated the new release last night, thx in adv.

PhrostByt
After you earn your points you have to claim them in Cortex.

hi, i saw the button now, after i uninstall razer cortex and reinstall again, probably some bug after yesterday update, thx.