Basilisk Ultimate Wireless Disconnecting after Win10 update | Razer Insider

Basilisk Ultimate Wireless Disconnecting after Win10 update

  • 22 June 2022
  • 1 reply
  • 13 views

Hey guys I'm currently dealing with a Wireless Basilisk Ultimate intermittently disconnecting and lagging AFTER a Windows 10 update. Details below.

This problem first occurred about a month ago where my mouse was disconnecting (when viewing the Razer Synapse App the Icon for my mouse would disappear and then reappear a 1-3 seconds later, continuously). Several common troubleshoots such as updating drivers, ensuring power mode on my USB port was off, reinstalling Razer software, and physical cleaning had no effect.

Eventually I uninstalled Synapse and just ran the mouse without any Razer software and the mouse resumed normal activity.

Last night, Windows decided to update itself during my shut down. Today when I powered up I immediately noticed the stuttering and disconnects had resurfaced. I looked for about an hour for known issues with Win10 updates pertaining to this mouse but wasn't able to fix on my own. Any help would be greatly appreciated.

This topic has been closed for comments

1 Reply

Userlevel 7
Belzie
Hey guys I'm currently dealing with a Wireless Basilisk Ultimate intermittently disconnecting and lagging AFTER a Windows 10 update. Details below.

This problem first occurred about a month ago where my mouse was disconnecting (when viewing the Razer Synapse App the Icon for my mouse would disappear and then reappear a 1-3 seconds later, continuously). Several common troubleshoots such as updating drivers, ensuring power mode on my USB port was off, reinstalling Razer software, and physical cleaning had no effect.

Eventually I uninstalled Synapse and just ran the mouse without any Razer software and the mouse resumed normal activity.

Last night, Windows decided to update itself during my shut down. Today when I powered up I immediately noticed the stuttering and disconnects had resurfaced. I looked for about an hour for known issues with Win10 updates pertaining to this mouse but wasn't able to fix on my own. Any help would be greatly appreciated.


Try resetting the mouse through the Razer Synapse 3.0's settings gear-like button at the top-right of the application. Also, update your computer's Intel drivers through this link. Ensure that your mouse's latest driver is installed. You can download it from the device's support page. Feel free to submit a case to our Support Team or send me a PM should you need additional assistance.