Help My Keyboard on my Razer Blade Stealth is broken | Razer Insider

Help My Keyboard on my Razer Blade Stealth is broken

  • 19 February 2019
  • 3 replies
  • 17 views

I just got this issue about yesterday. Firstly, i lost the chroma lighting on my keyboard on the blade (but, razer synapse still recognizes the keyboard and i can still change lighting effects), after a while sometimes the keyboard just wouldn't work but if i restart the keyboard would work without backlight, this happened when i was just watching youtube, i tried going back to previous versions of windows-nothing, reinstalling drivers-nothing, and i cant even reset the laptop, it would just be stuck on "Please Wait", no loading loop, i waited about 8 hours whilst i was asleep to reset the laptop but still, nothing changed,still on that "Please Wait" screen, before that i tried resetting it in the day while i was doing other stuff, about 4 hours i waited on that "Please Wait" screen.

Please help, i don't have any other device to bring to uni other than my phone to take notes.

This topic has been closed for comments

3 Replies

Userlevel 7
It may stuck on Windows load because some important files didn’t correctly installed. Can you access bios by pressing esc after booting or F9 to recovery menu? Note recovery F9 will sweep your ssd storage and put back in to factory form (out of box condition). Which Blade stealth do you have btw?
Joikansai
It may stuck on Windows load because some important files didn’t correctly installed. Can you access bios by pressing esc after booting or F9 to recovery menu? Note recovery F9 will sweep your ssd storage and put back in to factory form (out of box condition). Which Blade stealth do you have btw?


I have the 2016 model (RZ09-0168), ok i just started recovering in F9
Joikansai
It may stuck on Windows load because some important files didn’t correctly installed. Can you access bios by pressing esc after booting or F9 to recovery menu? Note recovery F9 will sweep your ssd storage and put back in to factory form (out of box condition). Which Blade stealth do you have btw?


I just completed the reset, nothing happened, do i have to redowonload drivers?