Kraken Tournament Edition - THX Spatial Audio not working. | Razer Insider

Kraken Tournament Edition - THX Spatial Audio not working.

  • 14 February 2019
  • 79 replies
  • 24 views

I've already chatted to a representative on support, and after everything he/she has offered to help with, nothing worked.
I've tried every solution on the internet including his support, and he eventually said I should get a replacement since it was from Amazon... It arrived today and to no avail, THX is still not working.

I've done everything in the book and looking for any advice, I've already tried restarting, reinstalling, plugging into another USB, resetting my PC, it just isn't working.

It worked before and to be honest I really don't want to return them... Not after I experienced the difference between normal stereo & THX.


I have Chrome and other Apps open that can use THX yet it's not displaying.
EDIT:
Also, none of the other equaliser options, voice clarity, sound normalisation works
It works on other PCs, namely my laptop

This topic has been closed for comments

79 Replies

Same issue here. It worked at first so I'm assuming it's an issue with Synapse still being in beta.

I really wish I would have known that they wouldn't even support this device in the OG Synapse. Mic issues galore and now this. The whole reason I bought it was for the THX Spatial Sound.

By the way, if you're having any issues with the mic crapping out, I found that if I turn it all the way down to 32000Hz keeps it functional. I still have to toggle the mic sensitivity any time i wake the computer though. Super annoying.

Report back if you find a solution to this issue. It's driving me crazy.
Try uninstalling Synapse using CCleaner so it removes all registry edits. Also uninstall the driver for the headset inside device manager and plug it back in so it installs the driver again. Then install Synapse to try again.
Try uninstalling Synapse using CCleaner
Userlevel 7
You can try few things first is create new profile with factory settings and see if work but remember to turn on THX and then player or webbrower sometime synapse have issue with recognize the app for THX. If you still have issue try to remove all razer softwere from your hard drive them go to appdata nad programfiles delete all files that stay after uninstall go to device menager remove the headset unplug and reboot pc when windows start go to razer website download new freash installer for synapse 3 and install just this next thing is plug the headset when everything will be ready reboot one more time pc to make sure changes are save and load. Try one more time and write back here if this help.
I am having the exact same issue on my new Kraken TE headset. I will try these suggestions and report back. If it doesn't work, I suppose I'll attribute it to an issue with the Synapse software and wait for a fix.


No joy. So I guess I wait for them to fix the Synapse 3 software.
hello guys , i just got mine a week ago it was working fine this happened same issue just like you i did everything ccleaner and every single method you can possibly imagine but still with the same issue , i guess i will have to use it without the razer synapse 3 😞 feelsbad no EQ no THX no Mic settings just the Default .
Synapse updated a couple days ago on my computer to version 3.4.331.31119. THX Spatial is still not working. **sigh**
still same...

its been 3 months since this post opened still doesnt work
You have to go to windows sound options, right click on your headset, and turn on windows spatial sound as well.
beerwithbatman
You have to go to windows sound options, right click on your headset, and turn on windows spatial sound as well.

nothing changed.. still the same
I'm having the same issue just worked the night before. shut down my computer and turned it on today and now nothing when using thx spatial through synapse
Somewhere between updating to Windows 10 1903 and the latest Synapse update resolved this issue for me. Applications are now listed again and I can toggle surround settings.
beerwithbatman
You have to go to windows sound options, right click on your headset, and turn on windows spatial sound as well.

This worked!! Thanks my dude, it was so annoying not having it for a few weeks.
I am getting and error code 10 on my Windows drivers for the THX Spatial - Synapse. Tried every single method with no avail. Mic and audio works 100% but as soon as Synapse is up and running sound works 100% but no Mic.. Nothing. even doing mic tests does not work. Any advice?
Hey guys so I don't know if this will work for yall but I have tinkered around with this for quite some time and I simply plugged the usb controller into a usb 2.0 not 3.1 and everything seems to work just fine
Hello,
If you are still having this problem I have the solution.
Open up Razer Synapse 3.0 and click on the RAZER USB AUDIO CONTROLLER.
Go to Mixer and there should be a list of apps. Go down a bit until you see Set as default. Go ahead and click that option and your audio should be back to normal.
Hope that helped.
erm I don't know if this is going to help anyone,but apart from the clean reinstall what worked for me is go to the sound settings on playback and on the Razer Kraken TE-Game i changed the default format from 24bit-96000Hz to 24bit-48000Hz.Is that a bug? How can increasing the Hz bug the spatial audio?
shareMardiGrassolo958
erm I don't know if this is going to help anyone,but apart from the clean reinstall what worked for me is go to the sound settings on playback and on the Razer Kraken TE-Game i changed the default format from 24bit-96000Hz to 24bit-48000Hz.Is that a bug? How can increasing the Hz bug the spatial audio?

If I set mine to 48000Hz zero sound is produced by the headsets, if I set it to 96000Hz I get sound but it won't allow 7.1 to be tested in the configure section of windows settings. I'm honestly sick and tired of having all of these issues ALL related to Synapse 3 and it's software, I'm also sick and tired of the developers working on the software being extremely lazy and not even bothering to fix the products they're supposed to be selling to consumers and just praying people repeatedly buy new shit.
I haven't been able to get 96000hz to work but I was able to get spatial sound to work at 48000hz. Go to:
Audio devices>Properties for thx spatial speakers>Spatial sound>Windows sonic(or whatever you may use)>Apply. Be sure to use the USB dongle and shift it to gaming as far as you can. For some reason this worked, even though I enabled windows sonic from the playback devices. Applying it through the sound manager seems to be the trick.
Screenshot for convenience. Let me know if it worked!
go to search and search for Sound Mixer Options then for master volume Output select the (THX Satial - Synapse)
and for the Apps Output select (Razer Audio Controller - Game),
this method fix the issue for me after a long time of massing around in the settings and i hop it will work for you guys.
blyat i solve issue, go into synapse->go to sound, scroll to "open windows sound properties", scroll to "Internal AUX jack" if u have, enable, u have boom boom in ear.
This happened to me some time ago. My headphones worked fine on another computer I have. I ended up doing a clean install of Windows after doing everything Razer support had me try over a month and a half time period. I don't know how many times I've uninstalled Synapse and disabled and uninstalled drivers and deleted registry settings and messed with all the other sound options. I did a system restore and that didn't work, either. After two months I figured I might as well do a clean install of Windows and it worked and has been since.
MattyIce598
Hey guys so I don't know if this will work for yall but I have tinkered around with this for quite some time and I simply plugged the usb controller into a usb 2.0 not 3.1 and everything seems to work just fine

Thank you. Can't believe I didn't try that.
This fixed the problem for me. I had it initially in a USB 2.0 port, worked fine.
Then I switched it over to a USB 3.1 port hoping to somehow be able to up the sample rate and bit depth to something higher than 16bit 48KHz (audiophile). Instead, I receive no output through THX Spatial driver.
It started working again with a USB 2.0 port.

If you want to use the headset at a higher bit depth & sample rate, plug it into an auxiliary port with the 3.5mm jack that is included with the headset. Sadly there is no THX spatial sound you can use with the auxiliary, only through USB.
See attached...
The Synapse software doesn't recognize any USB controller connected. The THX spatial audio button on the controller doesn't turn on. The LED light doesn't turn on either. Not sure if it's a software issue or a hardware one. I've tried all sorts of troubleshooting and nothing has worked so far.
innerperception
Hello,
If you are still having this problem I have the solution.
Open up Razer Synapse 3.0 and click on the RAZER USB AUDIO CONTROLLER.
Go to Mixer and there should be a list of apps. Go down a bit until you see Set as default. Go ahead and click that option and your audio should be back to normal.
Hope that helped.

It fking worked tnx