Kraken V3 Pro wireless connection problems | Razer Insider

Kraken V3 Pro wireless connection problems

  • 15 March 2022
  • 5 replies
  • 2470 views

Userlevel 1
HI Im having connection issues with my Kraken V3 Pro wireless. synapse 3 is not detecting the headset until i have done multiple thing to force synapse to recognise it, and after i restart my computer it loses detection of the kraken v3 again
Thing I have done to fix the issue

  • unplug and replug the wireless dongle
  • end all razer related tasks in task manager and restart synapse
  • run the repair program for razer synapse 3

i have to repeat this list of actions after every computer restart to get synapse to detect the headset again. I have also returned the headset to amazon ( where i got the fist headset ) and received a replacement which is having the same issues. i also have a Black Shark V2 Pro Wireless which has no issues on my system which tells me there is a problem specifically with the Kraken V3 PRO Wireless on the software side with synapse( because the headset has been replaced i assume there is not a hardware issue that is causing this). I believe it would require some kind of update to synapse to fix this. any other ideas would be appreciated. I like the Kraken V3 when it works, and all the features in synapse work when the headset is detected. I just want to resolve this detection problem so I can use the headset properly.

This topic has been closed for comments

5 Replies

Userlevel 7
Blayzer210
HI Im having connection issues with my Kraken V3 Pro wireless. synapse 3 is not detecting the headset until i have done multiple thing to force synapse to recognise it, and after i restart my computer it loses detection of the kraken v3 again
Thing I have done to fix the issue

  • unplug and replug the wireless dongle
  • end all razer related tasks in task manager and restart synapse
  • run the repair program for razer synapse 3

i have to repeat this list of actions after every computer restart to get synapse to detect the headset again. I have also returned the headset to amazon ( where i got the fist headset ) and received a replacement which is having the same issues. i also have a Black Shark V2 Pro Wireless which has no issues on my system which tells me there is a problem specifically with the Kraken V3 PRO Wireless on the software side with synapse( because the headset has been replaced i assume there is not a hardware issue that is causing this). I believe it would require some kind of update to synapse to fix this. any other ideas would be appreciated. I like the Kraken V3 when it works, and all the features in synapse work when the headset is detected. I just want to resolve this detection problem so I can use the headset properly.


Did you try pairing the headset to another computer? Try connecting the wireless USB dongle into another USB port too. Does the issue happen regardless of whether the Razer Synapse is running or disabled?
Userlevel 1
i have plugged it in to multiple ports on my computer the same issue occurs on each of them. the audio dose not work after a computer restart but unplugging the dongle and plugging it back in gets audio working, but synapse dose not recognise the headset until after i end all razer tasks in task manager and run the repair function through synapse. Windows ( windows 10 pro) recognises the dongle is there at all times when it is plugged in any where. i don't have another computer available to test with at the moment.
Userlevel 7
Badge +1
I think it's some software issue on your PC (problem with the system).

Be sure that your system is up to date (newest 21H2 version, all patches installed), also with .NET 4.8, update your Chipset drivers, BIOS if possible.

Remove synapse from your OS, then use this tool to remove any drivers/leftovers: https://rzr.to/Tf53xj additionally you can use CCleaner to cleanup your PC (and registry). After this restart your PC and download Synapse, install it as administrator.
Userlevel 3
I had this issues as you describe as well on all my PCs regardless drivers and OS version, also many other ppl have these issues. There is not really a fix yet, as its some weird bug/issue within the synapse itself. Lately it also causes whole app to crash, been reported many times already so we need to wait for a fix. Clean install with razer removal tool will fix the issue temporarily, as after some time it happens to happen again randomly.
Userlevel 7
Blayzer210
i have plugged it in to multiple ports on my computer the same issue occurs on each of them. the audio dose not work after a computer restart but unplugging the dongle and plugging it back in gets audio working, but synapse dose not recognise the headset until after i end all razer tasks in task manager and run the repair function through synapse. Windows ( windows 10 pro) recognises the dongle is there at all times when it is plugged in any where. i don't have another computer available to test with at the moment.


Thanks for sharing these details. Allow me to forward this to our Support Team. Please send me your MSinfo and Synapse logs, including a screenshot of the Windows version so I can initiate an investigation. I'll be locking this thread to divert our discussion privately.