My Viper V2 Pro won't charge or turn on | Razer Insider
Question

My Viper V2 Pro won't charge or turn on

  • 2 October 2023
  • 25 replies
  • 4433 views

I only got my viper v2 pro 2 months ago, and out of nowhere it stopped charging or turning on. When I plug it in, no lights turn on, no windows usb sound plays, and it doesn’t show up in the razer synapse dashboard either. I tried tapping the power/dpi button on the back, and I also tried holding it down for different amounts of seconds, and still nothing.

It was flashing red before this all happened, so I believe it ran out of battery.

I left it plugged in for 30 minutes just to see if it could gain a charge while unresponsive, but I still can’t get it to work.

Has anyone seen this happen before? Is there anything I can do to get it working again?


25 Replies

Userlevel 7

I only got my viper v2 pro 2 months ago, and out of nowhere it stopped charging or turning on. When I plug it in, no lights turn on, no windows usb sound plays, and it doesn’t show up in the razer synapse dashboard either. I tried tapping the power/dpi button on the back, and I also tried holding it down for different amounts of seconds, and still nothing.

It was flashing red before this all happened, so I believe it ran out of battery.

I left it plugged in for 30 minutes just to see if it could gain a charge while unresponsive, but I still can’t get it to work.

Has anyone seen this happen before? Is there anything I can do to get it working again?

Hi @Cinnabarsitetech391,

 

I would love to have this checked. Please PM me the serial number of your mouse so I can verify its model and check my resources for model-specific workarounds to help you address the charging problem of your Razer Viper V2. Thanks!

 

I have the same error as above please help me

Someone please help! this happened to me as well, my Razer v2pro wireless disappeared in my synapse and my mouse wont turn on.

Same problem, it just stopped working. It wont power on and isn't detected by Razer Synapse.

I have the exact same issue. Was working fine yesterday then this morning there is no light, won’t turn on or show up when connected directly to the pc via usb. Really frustr

hi everyone i have fixed this issue. dont plug it in to your computer, but rather plug it in to a socket directly using any adaptar and it switches on immediately. i hope this helps.

 

Hi everyone, yesterday I got a second-hand Viper V2 Pro and all was fine, but today I started the PC and the mouse couldn’t connect, couldn’t charge, and there was no response from the mice

Same issue here. Playing a game of Valorant, and the mouse just...died (from what I can tell. Left it charging all night with the included cable, restarted computer, nothing. 

Yo también tengo el mismo problema, de la nada el ratón dejó de funcionar y ni conectándolo al cargador funciona ni se carga, que alguien nos ayude por favor, no es un periférico barato. Gracias

 

Same issue here. Playing a game of Valorant, and the mouse just...died (from what I can tell. Left it charging all night with the included cable, restarted computer, nothing. 

 I had the same problem and after trying several things I apparently found the solution, after leaving it charging for a while I pressed the power button until the indicator LED turned on. I hope it helps you and forgive my mistakes in English, it is not my native language.

This type of stuff really gets me annoyed, I've had a few occurrences with razer products like this (pretty much the exact same thing happened with my laptop cord, after a couple of months it just broke.. and i bought a new one from a different company several years later no blemishes...) anyways I have the exact same issue as above. Sure enough I switched out the cable for the mouse and it works perfectly fine with a different cable. Plugged the Razer cable into my keyboard and sure enough, it doesn’t work. This kind of feels like my last straw. I mean i have had the mouse for legitimately less than 30 days, never did anything to harm the cable whatsoever and out of nowhere, after no significant action it simply breaks. I would want a fix to this but then again aside from getting a whole new cable and having the same thing likely happen again I can only wonder what will happen next.

This was happening to my buddy until today-

Try a different PC first- if available- to see if it will charge. Otherwise look for recent updates and try a rollback. Probably a recent update killing it but I don’t have my hands on his PC right now so not sure if it was AMD, Windows 11, or Razer’s stuff. 
 

this worked with the original chord too- he literally just plugged it in to his roommate’s PC (windows 10, no razer synapse products) and it lit right up from being completely dead even will wired. 
 

Hope this helps!

This was happening to my buddy until today-

Try a different PC first- if available- to see if it will charge. Otherwise look for recent updates and try a rollback. Probably a recent update killing it but I don’t have my hands on his PC right now so not sure if it was AMD, Windows 11, or Razer’s stuff. 
 

this worked with the original chord too- he literally just plugged it in to his roommate’s PC (windows 10, no razer synapse products) and it lit right up from being completely dead even will wired. 
 

Hope this helps!

Follow up- he now is able to plug it back into his PC after charging on the other. Possibly a driver issue that was reinstalled via the hookup to the secondary PC? Not sure. 

Same problem

Same problem 

Just happened the same with mine too. 

 

Got it 2 months ago. 

 

Warranty solves this? What can I do? 

Mines dead too! Was using it wired and it just went out! Nothing happened to it,it was in my hand! lol. Lovely to see so many issues and 0 fox shown from Razer about it! I tried all the tricks above and nothing.. just a really expensive door stop!  If there is ever a class action, let me know… NOW i understand why there is so much hate for Razer! Sad really... 

I also had the same problem, wouldn’t turn on anymore, and all. But i read trough what was written above here… and found the solution from MaykGR above. I did the same, as in putting it on charge for a while (you don’t see it and computer doesn’t recognize it). Than I held the on/off button in for like 10 seconds till the led on top started blinked… and my mouse works again as before 

SOLUTION!!

Drove me insane thinking it just died

  1. Plug into wall (can try into PC usb if you don't have a wall plug)
  2. Hold power button for 10 secs or more until it resets

SOLUTION!!

Drove me insane thinking it just died

  1. Plug into wall (can try into PC usb if you don't have a wall plug)
  2. Hold power button for 10 secs or more until it resets

YESS THANK YOU

My one wasn’t able to be found on Razer synapse and only worked if I plugged it into my computer directly. When it was plugged in it was reading 0 battery and when I plugged it off it disappeared again. I unplugged my hyperpolling dongle and plugged it back in and it fixed the issue and even showed that my mouse was indeed charged. I think this would also work if you didn’t have the dongle. Just unplug and plug the dongle back in and should work. May be a connection glitch.

Very similar issue here. My mouse is functional if I have it plugged in at all times, but in Synapse it shows it’s battery to be at %0. When I try to use the mouse wirelessly, it is completely nonfunctional and disappears from Synapse.

SOLUTION!!

Drove me insane thinking it just died

  1. Plug into wall (can try into PC usb if you don't have a wall plug)
  2. Hold power button for 10 secs or more until it resets

Dam man, thank you u save my life <3

SOLUTION!!

Drove me insane thinking it just died

  1. Plug into wall (can try into PC usb if you don't have a wall plug)
  2. Hold power button for 10 secs or more until it resets

oh my god thank you so much

Ninguna solución funciona :'(

Reply