Need to unplug and replug my dongle when starting windows for Barracuda X to connect | Razer Insider

Need to unplug and replug my dongle when starting windows for Barracuda X to connect

  • 19 December 2022
  • 38 replies
  • 3198 views

Userlevel 1
Hi, new here, just started using razer products, I just bought a razer barracuda X headset, with wireless and bluetooth support. I'm using it for PC with the wireless dongle. All is well, but when I turn on my pc or restart windows and power up the headset, it just won't connect, tries the wireless and then the bluetooth pairing. The only thing I need to do is just unplug and replug the dongle; it's not that much of a deal, but is this supose to happen do I need a driver or software for fixing this? My windows version si 10 19045.2364 build. Does anyone have a solution for this, would be much appreciated! Thank you and have a good day!

38 Replies

Since a few weeks i have the same Problem. No Solution so far.
I tried an other USB-Port with an USB-A to USB-C adapter and tried to uninstall the Device and reinstall it, the problem continues.
I'm running WIn11 22H2.

Anyone has an idea?
Just to bring it up again. The Problem still exists.
Is it already adressed, or is there any hint or advice yet?

Try uninstalling headset drivers.

  1. Press Windows key + S on the keyboard to open the Search bar.
  2. Type in “Device Manager" and hit enter
  3. Go to “Audio inputs and outputs".
  4. Right-click on the Razer headset and select “Uninstall device".
  5. Restart the computer to completely uninstall the drivers. The drivers are automatically installed on the computer after a restart.

I had the same issue, and i did a little “research”. Turns out there’s an official pairing tool for the barracuda x:

How to use the Razer Headset Pairing Utility

No need to uninstall drivers. Worked for me.

I had the same issue, and i did a little “research”. Turns out there’s an official pairing tool for the barracuda x:

How to use the Razer Headset Pairing Utility

No need to uninstall drivers. Worked for me.

Omg it helped! Thx man ! 

I don’t know if there’s a difference between Barracuda X and Barracuda but this isn’t working for me.

I had major issues yesterday with the connection, which forced me to completely remove everything.

I uninstalled all drivers, driver for dongle, updated firmware etc.

Now connection is back and headset isn’t turning off after 5 seconds.

But i’m back to having to unplug and replug the usb c dongle after every boot. I’ve paired the device 3 or 4 times.

Same problem here with the barracuda X, pairing tool doesn’t work as a solution since it seems the usb c dongle isn’t detected after windows restart, and the pairing tool needs to detect for it to work. The only way to get windows to detect it is to unplug and re-plug the dongle. This is disappointing because the only usb C I have is on my motherboard, so I have to turn my whole computer around just to get the headset to connect. 

Hopefully we can get a real solution here soon..

 

I too am having this problem. It was working before the last update to synapse. Nothing I have done (uninstall, ect) has fixed it. I have a Barracuda X also. 

Have EXACTLY the same problem with my new Barracuda X (2022)…. did anybody solve this problem? Is there a solution, OR will I really have to go for a different headset?

Same as everyone else. I did an RMA and everything and I’m still getting the same issue. Unisntall/install drivers, try different ports (direct to USB C port, using the USB A to C dongle, etc). I’m on Win11 and so far I’m just using the amazingly long USB A to C adapter to keep the dongle in a somewhat easy to get to spot so at least when I disconnect reconnect the dongle it’s not entirely inconvenient. My guess is gonna be that it’s potentially a Windows 11 issue since it seems most of the product assist thingies are for Windows 10 (the 7.1 surround sound, for example).

Same as everyone else. I did an RMA and everything and I’m still getting the same issue. Unisntall/install drivers, try different ports (direct to USB C port, using the USB A to C dongle, etc). I’m on Win11 and so far I’m just using the amazingly long USB A to C adapter to keep the dongle in a somewhat easy to get to spot so at least when I disconnect reconnect the dongle it’s not entirely inconvenient. My guess is gonna be that it’s potentially a Windows 11 issue since it seems most of the product assist thingies are for Windows 10 (the 7.1 surround sound, for example).

nope im using window 10 and im having same issue, has to be a software issue, it why razer recommends unticking the “turn device off feature” is the usb power setting. once the dongle gos into sleep mode it wont turn back on until you unplug and replug it in but once the PC powered down it will automatically go into the sleep state and wont turn back on when booting. 

Same as everyone else. I did an RMA and everything and I’m still getting the same issue. Unisntall/install drivers, try different ports (direct to USB C port, using the USB A to C dongle, etc). I’m on Win11 and so far I’m just using the amazingly long USB A to C adapter to keep the dongle in a somewhat easy to get to spot so at least when I disconnect reconnect the dongle it’s not entirely inconvenient. My guess is gonna be that it’s potentially a Windows 11 issue since it seems most of the product assist thingies are for Windows 10 (the 7.1 surround sound, for example).

nope im using window 10 and im having same issue, has to be a software issue, it why razer recommends unticking the “turn device off feature” is the usb power setting. once the dongle gos into sleep mode it wont turn back on until you unplug and replug it in but once the PC powered down it will automatically go into the sleep state and wont turn back on when booting. 

I also tried unticking that option, as well as the “let the PC turn off the port so it can sleep” (or whatever) feature - no results there for me.

same i done everything so far Razer recommended and thing that already commented in this forum but nothing has worked. Just Waiting for Razer to look into it and release a update for the device. 

Same problem for me too.  Have tried everything mentioned in this thread but still not working

 

At least I am not the only one getting this issue, the more people get this issue, the more chance there is Razer will fix it

 

Hello guys, I bought a Barracuda X and I have this exact problem. I have to take off and put in again the dongle in the usb-c for it to be recognized.

Has anyone found a fix for this or has RAZER said anything about this issue?

 

Thanks.

Userlevel 1

Same problem here with a Kraken v3 Pro. A $200 headset. 
The pairing utility does NOT fix it.

This is totally unacceptable.

Barracuda x 2022
Same problem. Tried USB power options and pairing util. No luck.
Also wrote Razer. They suggest I install synapse… what? It’s Barracuda X 2022. Not supported by Synapse.


Please wake up Razer.

#https://www.trustpilot.com/review/razer.com
 

Userlevel 1

After weeks, talking to Support, they making me use the “pairing tool”…   everything is the same. 🤦🏻

It works for some days…   and then goes back to not working again, forcing to unplug and replug.

How this company can get away with selling products so expensive that work so bad?

You need to unplug and replug your Barracuda X headset's dongle when starting Windows to connect. To resolve this issue:

1. Update headset and dongle drivers.
2. Try different USB ports or avoid USB hubs.
3. Adjust power management settings.
4. Check for firmware updates.
5. Verify antivirus/firewall settings.
6. Configure automatic reconnection.
7. Contact manufacturer support if the issue persists.

hope its clear for that

Userlevel 1

And after losing your precious time doing all that, and checking (once again) that 🔴it DOES NOT SOLVE THE PROBLEM🔴…
 

  1. Write support AGAIN for them to make you loose more time doing more random stuff that do not solve the problem

I bet this can only be fixed by a firmware update. But all my software, drivers and firmwares ARE ALREADY UPDATED, so it seems in (at least) 🔴EIGHT MONTHS🔴 Razer couldn’t come up with a solution. So maybe it is because they are totally incompetent or maybe it is a hardware fault, it can NOT be fixed and so their best policy is to make us lose time repeating the same useless steps until we desist out of boredom...

I’m having same problem. The funny thing is that the old version of Barracuda X doesn’t have this problem. My old one was made in 2021, and have plugs on middle of dongle, not the side. Also, it plays melody when it turns on or off, not that weird mechanic lady voice.

 

Anyway, with that version, it was perfect. But the current one is a disaster. I already got exchange once but having a same problem. I think I have to find some other products...

I found out that Barracuda X itself doesn’t have a problem.

Barracuda X plus however has ther problem. (If your box says Barracuda X with Bluetooth logo on it, it’s X plus)

 

I ask support to Razer team and all the thing they suggest is

  • get a exchange
  • Airblow the USB slot
  • Try to use Synapse (while Barracuda X plus can’t be used in Synapse)
  • get a refund

 

I don’t know why they call themselves as “Technical” support.


After taking a look those ‘support’, I see what would happen if I use some pricy product in future. This would be my last time using Razer product.

I have one solution, intead of using Razer dongle you can use bluetooth adapter and connect through bluetooth.

Works for me in win11

Userlevel 1

I have one solution, intead of using Razer dongle you can use bluetooth adapter and connect through bluetooth.

Works for me in win11

Interesting…   does that works exactly the same, with Synapse recognizing the headset and allowing you to set options, THX Spatial sound, etc ?

Reply