Razer Blade 15 Advanced 2019 - Speaker crackling | Razer Insider

Razer Blade 15 Advanced 2019 - Speaker crackling

  • 14 February 2020
  • 4 replies
  • 1 view

Hi there,

Got my first Razer Blade back in July 2019, and I have LOVED every second of it. Recently I've noticed some light popping and crackling sounds from the speakers when I'm listening to Spotify at work. I guess it's been going on for about a month or so, but maybe longer and I'm only noticing it now. When I'm home, I use my Airpods while I game, and the sound is superb, this seems to be an issue only when using the laptop speakers.

I've tried to download the older version of the Realtek driver (R2.82), described in the forum post here. After restarting a few times, I booted up Spotify to test it out, (iTunes as well) and the crackling is still there. I'm hoping this is not a hardware issue. Does anyone have any experience with this, or know of any other things I should try?

This topic has been closed for comments

4 Replies

Userlevel 7
Maybe try to reinstall windows if old Realtek driver etc didn’t solve the issue like on stealth. However before doing that I’ll change the tag to support hope staff will pick you up there and have other solution the issue.
SenorSnoo
Hi there,

Got my first Razer Blade back in July 2019, and I have LOVED every second of it. Recently I've noticed some light popping and crackling sounds from the speakers when I'm listening to Spotify at work. I guess it's been going on for about a month or so, but maybe longer and I'm only noticing it now. When I'm home, I use my Airpods while I game, and the sound is superb, this seems to be an issue only when using the laptop speakers.

I've tried to download the older version of the Realtek driver (R2.82), described in the forum post here. After restarting a few times, I booted up Spotify to test it out, (iTunes as well) and the crackling is still there. I'm hoping this is not a hardware issue. Does anyone have any experience with this, or know of any other things I should try?

Hi there! Can you share a video of the issue? Just as what @Joikansai had mentioned, please try to reinstall the drivers and see if it helps. Let me know.
Here's a link to the video. It's pretty intermittent, but really comes out for instrumental piano stuff (which is mostly my work music) -

I did the driver uninstall and update again. Didn't seem to change much. I did do some Youtube stuff and noticed that the crackling really isn't there for it... Gonna do some more fiddling around, maybe reinstall Spotify. Would rather not reinstall windows if I can avoid it... Fingers crossed.
@SenorSnoo RedPanda is currently out of the office, so I'll be taking over. Does the cracking noise become apparent only when on max volume? The best way to isolate which frequency range is causing the cracking would be to use 1 track and turn all the sliders on the EQ all the way down. You can then individually turn up one slider at a time to see which is likely to trigger the cracking noise. Anyways, please send me a PM so I can help you further isolate the issue.