Razer blade 15 won't turn on | Razer Insider

Razer blade 15 won't turn on

  • 23 December 2021
  • 1 reply
  • 1 view

I just received my new razer blade 15 RTX 3060 / 144HZ this morning. I was able to start it up and do the standard login stuff. Then I turned it off. A couple hours later I wanted to start te laptop and it didn't turn on. The led on the adapter glows but the one on the laptop doesn't. The laptop is also really cold so I don't think that it is charching at all. I have had the charger connected for at least 4 hours but it still won't turn on.

I have tried clicking and holding the power button on the laptop with and without the adapter connected to it.

Do you have any idea what is wrong with it?

This topic has been closed for comments

1 Reply

Userlevel 7
RileyMat
I just received my new razer blade 15 RTX 3060 / 144HZ this morning. I was able to start it up and do the standard login stuff. Then I turned it off. A couple hours later I wanted to start te laptop and it didn't turn on. The led on the adapter glows but the one on the laptop doesn't. The laptop is also really cold so I don't think that it is charching at all. I have had the charger connected for at least 4 hours but it still won't turn on.

I have tried clicking and holding the power button on the laptop with and without the adapter connected to it.

Do you have any idea what is wrong with it?


What a flop! Were you able to perform the steps from this article? Feel free to submit a case to our Support Team or send me a PM should you need additional assistance. I'll be locking this thread now.