Razer Deathadder Elite not showing on synapse dashboard | Razer Insider

Razer Deathadder Elite not showing on synapse dashboard

  • 20 March 2022
  • 2 replies

I've had this mouse for well over 2 years at this point, and it worked great. I adjust my DPI on the razer synapse app and all was well with the world

But then Synapse 3 came

For about 3 months now, my mouse hasn't shown up on the dashboard of Synapse and I can't adjust the DPI modes. It's really starting to drive me mad, so much so that now I'm here, needing help.

I have tried the following:
unplugging the mouse, waiting 60 seconds, plug it back in
rebooting the computer
registering the mouse
I checked for firmware, but the Deathadder Dlite doesn't use any

The DPI buttons still adjust up and down, but only to the default modes, none of which are my preference. Please someone help I'm getting desperate because my clicks have gotten so bad.

This topic has been closed for comments

2 Replies

Userlevel 7
Uninstall Synapse, then download this tool to remove any Razer drivers: https://rzr.to/Tf53xj
After using this tool reboot your PC, and install Synapse again (as administrator).
That did it! Thanks a ton!