Razer hammerhead True Wireless earbuds dosen't work | Razer Insider
Question

Razer hammerhead True Wireless earbuds dosen't work

  • 15 November 2023
  • 5 replies
  • 174 views

Couple days ago I bought razer hammerhead tw headphones. I charged them till the case indicator LED was green. I opened the case and removed the earbuds, turned on the bluetooth on my Iphone 12 and tried to find the headphones. I waited 1-3 minutes to find them but nothing happened. There wasnt any audio indicator.

The case and earbuds are fully charged, when its plugged into the charger case LED is green. I downloaded the razer audio app in my Iphone. I had bluetooth enabled, case closed with earbuds inside them. I clicked search and the app found my earbuds even got the color correct (mercury). After it showed my earbuds when I tried to click connect (still with the case closed and earbuds inside the case) it shows error about missing earpiece that one of my earbuds isn't charged. After the errors I removed the earbuds from the case and placed them next to my Iphone and clicked search again but it couldn't find any devices, even tho with case closed and earbuds inside the case it SOMEHOW found them. I tested with android device as well, it found them with case closed and earbuds inside them, but this time the android device connected successfully to my earbuds inside closed case and showed both earbuds 100% charged. But even then as soon as I took the earbuds outside the case connection was lost.


5 Replies

Same issue here, recently purchased 2 days ago, brand new from Amazon.es, after i left them to fully charge i spent all day today to try and troubleshoot them and get them to work, reading a lot of forums, redit, youtube but to no avail :( they are DOA :( and they were supposed to be a Christmas gift for my wife (good thing she wanted to open them early) 

 

Also just now i found out Razer no longer supports this product (i guess thats why these were heavily discounted on amazon 62% discount) so i initiated a full refund on amazon, now i need to go to a drop off point after Christmass and they wait for 14 days for the refund etc. Not a very good experience, pretty frusttrating i might add :( 

Same problem

I’m having the EXACT same problem

Same issue here, recently purchased 3 days ago, brand new. after i left them to fully charge i spent all day today to try and troubleshoot them and get them to work, reading a lot of forums, youtube but to no avail :(  so please help me with it..

 

Mismo Problema!

Reply