Razer Nari Ultimate rapidly disconnecting | Razer Insider
Question

Razer Nari Ultimate rapidly disconnecting


Userlevel 3

Having the same issue as many others here - Razer Nari Ultimate worked fine for a long time now all of a sudden is rapidly disconnecting/reconnecting on PC/PS5 - causing playback issues and of course forcing me to use 3.5mm jack - reached out on twitter troubleshooted everything from the recovery tool to having my case escalated to “advanced support” but its been 5 days without reply

USB ports work for anything else just the headset keeps cutting out and its infuriating - please assist as this is my third locale for support


105 Replies

i have same bloody issue ive looked through as much as i could without support and havnt found one solution 

Userlevel 7

It’s highly likely that the dongle is defective. Please PM me your case number so I can coordinate with the relevant team and check our options. Thank you!

It’s highly likely that the dongle is defective. Please PM me your case number so I can coordinate with the relevant team and check our options. Thank you!

I have the same exact problem, could u also help me?

same freaking issue for 2 days now … after 5-10 minute from PC turning on , it starts rapid random disconnect 

Tried everything , connect reconnect the USB , uninstall install the synapse aaand still happening .

Randomly it starts working again but then disconnects after a while

 

…. is there any solution ?

Same thing here, bought a super expensive dongle replacement from china, waiting for arrival and praying that will solve the problem

Also heard that there is a tool for pairing a new dongle, hopefully that will work as well 

honestly what a ridiculous flaw in such a expensive headset, I knew it from the start that dongle was far to cheap for a headset like this, not to mention the range is REALLY short.



 

I have same issue just today got to me when i charged my nari ultimate with chargeur of phone i think its battrie let go so the problem with battrie not dongle i think

Userlevel 7

Hi guys!

 

Feel free to PM me the serial number of your headset so I can validate its model and check our options. Thank you!

i've got the same issue with the headset tried severel thing but could not fixe the issue, been having this isue almost a week 

Having the same issue just started all it’s doing is rapidly connection and disconnecting from my pc Bluetooth audio if there is a fix pls dm me. I've already tried a clean install of synapse and all but problem still persists.

 

Userlevel 7

Having the same issue just started all it’s doing is rapidly connection and disconnecting from my pc Bluetooth audio if there is a fix pls dm me. I've already tried a clean install of synapse and all but problem still persists.

 

Can you PM me the serial number so I can validate its model and check for other options for addressing the connection problem of your headset? Thank you!

my headset stopped appearing at the audio section and it keeps disconnecting from my pc and i tried everything to fix the problem but i can't find a bloody sollution

Having the same issue and it just started couple days ago. PMd informations on the Dongle already. 

 

Wondering if Win10 update didnt break it *ponders*

 

nyways, ill wait for support official statement.

having the same issue ,obviously its a razer problem with the amount of people with the same issue!

I am also having the same issue, sounds like something else is up.

Same issue. PM sent.

It’s highly likely that the dongle is defective. Please PM me your case number so I can coordinate with the relevant team and check our options. Thank you!

i need help been an issue for at least since this thread and didnt see this thread till now, have loved this headset but this makes me literally want to chuck it against a wall and makes my stress and anxiety go thru the roof, i just want to play my games not hear beep boop beep boop beep boop over and over and over. theres nothing that has fixed for me. finally am buying y splitter and aux cable make sure you get trrs so the mic works but this takes away the haptic and all the other ultimate features. But yea have had many rage sessions all induced to just this lol

This is happening to my headset as well connects and disconnects over and over...

This is happening to my headset as well connects and disconnects over and over...

noticed that it seems to stay connected fine if I continue to use another headset but the moment I make them my default device it will last for maybe a minute or 2 then start disconnecting and reconnecting.

Same issue with disconnecting sent my info in.

Same thing here, bought a super expensive dongle replacement from china, waiting for arrival and praying that will solve the problem

Also heard that there is a tool for pairing a new dongle, hopefully that will work as well 

honestly what a ridiculous flaw in such a expensive headset, I knew it from the start that dongle was far to cheap for a headset like this, not to mention the range is REALLY short.



 

 

I just bought the thing today and have this issue… Itll keep beeping disconnecting and reconnecting but never actually be disconnected. Have everything updated.. 

Having the same issue just started all it’s doing is rapidly connection and disconnecting from my pc Bluetooth audio if there is a fix pls dm me. I've already tried a clean install of synapse and all but problem still persists.

 

Can you PM me the serial number so I can validate its model and check for other options for addressing the connection problem of your headset? Thank you!

I also have been experiencing this same issue for the past 2 weeks  except on the ps5 and have tried everything but nothing seems to work. I look after it as it is a expensive purchase, so I would really like help with the fix of this @Razer.Zionzedd !!!!

having the same issue ,obviously its a razer problem with the amount of people with the same issue!

any good news?

ive had the same issue for a long time, ive been using cable connection for over half a year now and its soooo annoying. i found the pairing utility earlier and it made wireless work for a hour until it started disconnecting and connecting a couple times until its just wont connect at all again. so i guess im back to using the jack cable.

i really hope razer does smth about this 

 

Edit: i did try the pairing utility multiple times again but it keeps going from 25% to 45% back and fourth and then eventually saying pairing failed 

Another thing, sometimes when i plug in my usb dongle windows says it doesn't recognize the device and that it could me malfunctioning and no its not the usb port the port is fine with other stuff but this happens here and there 

Reply