Razer Nari Ultimate rapidly disconnecting | Razer Insider
Question

Razer Nari Ultimate rapidly disconnecting


Userlevel 3

Having the same issue as many others here - Razer Nari Ultimate worked fine for a long time now all of a sudden is rapidly disconnecting/reconnecting on PC/PS5 - causing playback issues and of course forcing me to use 3.5mm jack - reached out on twitter troubleshooted everything from the recovery tool to having my case escalated to “advanced support” but its been 5 days without reply

USB ports work for anything else just the headset keeps cutting out and its infuriating - please assist as this is my third locale for support


106 Replies

FIX!!!

 

If anyone is still having problems with the connection and disconnection. I plugged my usb dongle to a 3.0 port on the motherboard from the back, instead of the regular 2.4 and the problem vanished instantly. I thought maybe the dongle needs a 3.0 usb port for it to function more efficiently? Also the range has also increased and no problems persisted. 
Hope this helps💪🏽

nice to know you didn’t fix anything and you have AMD very helpful, thanks!

FIX!!!

 

If anyone is still having problems with the connection and disconnection. I plugged my usb dongle to a 3.0 port on the motherboard from the back, instead of the regular 2.4 and the problem vanished instantly. I thought maybe the dongle needs a 3.0 usb port for it to function more efficiently? Also the range has also increased and no problems persisted. 
Hope this helps💪🏽

So there’s 2 problems that seem to cause this;
one is the known, that usb dongle just isn’t pulling enough juice and that “fuse” isn’t a fuse at all, it’s a resistor and bridging it is increasing the power (not entirely recommended)
secondly is weirdly the in the right ear cup, the circuit that controls the master volume, specifically the potentiometer itself.

You can determine which one is a problem by fiddling with the volume wheel and if the disconnects either stop or discernably change in frequency, then it’s the potentiometer and it needs to be replaced. If twiddling the wheel does nothing then the dongle is bad. The protocols of the dongle could be cracked and replicated mostly easily and replacement dongles could be fabricated. Razer could also give us schematics to aid repair and software to pair some generic replacement 2.4ghz dongles too, but razer aren’t a fan of you repairing their products, they’d prefer if you just spend hundreds more on the next device that’s designed to break/fail in 15~ months. Razer being anti-repair S.O.Bs and I can’t wait til they have to change their tune when the lawman comes

Hello Guys! I have Nari Ultimate two years ago, and i had the same problem. I was lucky, because my warranty was live, and now, Nari is in service. But, i found a solution on the Reddit.. It’s connecting with a SMD fuse on the dongle. Maybe, it could help. Don’t forget, BE CAREFUL! (if you try this)  Read with attention, and follow the steps exactly. 

The Reddit post: https://www.reddit.com/r/razer/comments/12jwyqh/razer_nari_ultimate_dongle_connection_issue/

If you are running Windows 11 and have the latest january security update installed on your computer, it might be the problem, i found this article from Windows Latest's website, talking about audio issues after Win 11 january security update:  Windows 11 KB5034123 January 2024 update won't install, users flag installation issues (windowslatest.com) if u wanna try some workarround you can remove this supossilly problematic KB by following this tutorial: How to uninstall an update on Windows 11 - Pureinfotech you should look at: KB5034123 in the installed updates list.

Hello Guys! I have Nari Ultimate two years ago, and i had the same problem. I was lucky, because my warranty was live, and now, Nari is in service. But, i found a solution on the Reddit.. It’s connecting with a SMD fuse on the dongle. Maybe, it could help. Don’t forget, BE CAREFUL! (if you try this)  Read with attention, and follow the steps exactly. 

The Reddit post: https://www.reddit.com/r/razer/comments/12jwyqh/razer_nari_ultimate_dongle_connection_issue/

Same problem and out of warranty !

I contact Razer directly who ask me  questions and many no correspond to the problem.. no sense !
Are they want my d** size too ?

They know the problem et don't want to do anything !

I regret to bought this headphone !

bye Razer

Pretty fed up by having to run the dongle recovery tool and the pairing utility over and over again. Can anyone please reply if PM-ing the razer guy did actually help?

So this is happening to me to now, of course out of warrnty. Dongle repair doesnt work, reinstalling doesnt work either, it seems at this point this should have been a mass recall for a defective product with how many are havving this issue.

 

Whats going to be done for us? am i out 200$? my wife has the same headset and its starting to happen to hers as well… slight disconnects here and there, just her dongle still shows as a razi nari ultimate not some random avnera av6301 device.

Having the exact same issue as everyone else. Just started today.

Tried to pairing tool = no success
Tried the dongle repair = no success

Trying to PM support now.

 

i have same issues did you guys find any fix for this? 

I paid 200 eur for this headset and out of warranty since few weeks.. 😥

This just started happening to mine now. I think I have had it for a year? I thought I was going crazy. It would even kill everything else on my USB hub. Yes. I tried just using it on the hub and just using it on any plug on my desktop same thing. On and off on and off. 

Same. When I try to hookup up my Razer Nari’s to my PS5 Slim, they will work for a bit and then randomly disconnect. Then when I replug it, it starts to reconnect and then disconnect back and forth until it won’t connect anymore. 

Hello I have the same Razer nari ultimate headset and recently the headset does not work through the dongle

it shows up for a few seconds in my audio control pannel but when trying to select/use it , it dissapears and nothing happens

 

i too atempted the dongle repair app , but it made no difference

I think i bought the headseds about two years ago .

is there a solution to this that helps fix it 

 

I have just started having this problem today. 11/13/23. My Razer Nari Ultimate just keeps disconnecting and reconnecting as soon as audio starts playing in it. I’ve tried the dongle recovery, the firmware update and there doesn’t seem to be a problem. I went to Youtube and Reddit to find solutions, but nothing seems to work. Is it over???

Hi..

I am having the same issue and this is after 7 months..


It will connect for a while, with sound, and then all of a sudden disconnect..
It will then go through the connect / disconnect cycle continuously for about 2 minutes..


Connecting it to another USB port repeats the above process..

 

I have tried the recovery process mentioned, which was painful due to having to try run it multiple times due to connection, BUT the issue was not resolved.. :(

@Razer.Zionzedd - can I pm you my S/N, etc?

After years of use with no issues my razer now also started to randomly disconnect after a few minutes of use, is it the dongle, and if so, what can/should I do to replace it? Currently living in Belgium.

 

Same problem here. I opened a support ticket. Let’s see what happens.

 

I also tried both the Pairing Utility and the Dongle Recovery tools and both seemed to fix it at first but as soon as you set the headset as your sound device and start something that plays sound like a Youtube video it immediately goes back into the “pairing” mode and keeps connecting and reconnecting.

Exact same problem as everyone else on here. My Razer Nari Ultimate has worked completely fine for almost 2 years now, but as of today it keeps dropping out, trying to reconnect, and then fails in the end… Tried dongle in multiple ports but the problem is with the dongle :( What can be done to fix it? Is there software update or is it a hardware malfunction?

SAME ISSUE I CONTACT TODAY THE PM razer guy, lets see what happens.

The first of this headset the support team said to take back, as I would turn it on and it would turn off, now I have the replacement and have had it for a month now and I realized its the USB Dongle the whole time.  I have the dongle on the LED light Razer headset stand and when the USB Dongle drops it causes power to the device to drop, Any USB Port I plug it into it causes a voltage loss and then comes back.  How do I get a replacement fixed Dongle?

 

P/N RZ04-02670100-R3U1

Wireless USB  Transceiver P/N RC30-0267

S/N 862135D09100221

 

I just got this issue to and its really frustrating that it doesnt work.

I still have the original packaging with serial nummer is there away that i can get help with this or there is nothing more to be done.
 

same problem here, though im out of warranty, bought it more than 3 years ago
 

After owning this headset since release, I just started having this issue a few days ago. Its driving me nuts with the constant beeping. Hopefully there’s a fix for it soon

Userlevel 3

Same, my issue is worsening as well. The dongle isn’t connecting anymore.

Same problem here, worked fine for 8 months until 2 weeks ago.
Headset start rapidly disconnecting and reconnecting when I try to use the microphone, tried the recovery tool for dongle but it get worse, now i cannot connect anymore.

Reply