Razer Nari Ultimate rapidly disconnecting | Razer Insider
Question

Razer Nari Ultimate rapidly disconnecting


Userlevel 3

Having the same issue as many others here - Razer Nari Ultimate worked fine for a long time now all of a sudden is rapidly disconnecting/reconnecting on PC/PS5 - causing playback issues and of course forcing me to use 3.5mm jack - reached out on twitter troubleshooted everything from the recovery tool to having my case escalated to “advanced support” but its been 5 days without reply

USB ports work for anything else just the headset keeps cutting out and its infuriating - please assist as this is my third locale for support


111 Replies

It’s highly likely that the dongle is defective. Please PM me your case number so I can coordinate with the relevant team and check our options. Thank you!

i need help been an issue for at least since this thread and didnt see this thread till now, have loved this headset but this makes me literally want to chuck it against a wall and makes my stress and anxiety go thru the roof, i just want to play my games not hear beep boop beep boop beep boop over and over and over. theres nothing that has fixed for me. finally am buying y splitter and aux cable make sure you get trrs so the mic works but this takes away the haptic and all the other ultimate features. But yea have had many rage sessions all induced to just this lol

Hello,

 

Same problem for me, after 1,5 year without any problems.

I tried all of the following procedures, none worked:

I see that this problem is not recent and that no fix has been made by Razer.
So I think I'm not going to wait for a fix and send back for warranty...

I was having the same problem.  The solution that fixed my problem was executing Nari Dongle recovery tool and executing the Nari Ultimate pairing utility tool (that is the headset I have, there are other utility tools depending on the style you may have).

It’s highly likely that the dongle is defective. Please PM me your case number so I can coordinate with the relevant team and check our options. Thank you!

I have the same exact problem, could u also help me?

I have the same problem in my Razer Nare Ultimate. It connect and disconnect quickly. I tried the tools that Razer publish but they dont work in Windows 10 (i actuallized all).

I try the headphones in other PC with Windows 11 and it worked correctly but not work in Windows 10.

Hello,

 

Same problem for me, after 1,5 year without any problems.

I tried all of the following procedures, none worked:

I see that this problem is not recent and that no fix has been made by Razer.
So I think I'm not going to wait for a fix and send back for warranty...

having the same issue ,obviously its a razer problem with the amount of people with the same issue!

Hey! I know this wont fix the dongle USB issue, and you will lose the wireless feature but you can still use the headset and microphone: you can use the 3.5mm cable and attach a cable splitter to it (dividing into two cables, mic and audio) and connect them to your computer, sure is cheaper than a new headset or a USB dongle, and you can use the headset you bought which is already expensive. Using the splitter it wont be recognized on synapse

 

Wont buy any Razer product again. Cheers!

Same thing here, bought a super expensive dongle replacement from china, waiting for arrival and praying that will solve the problem

Also heard that there is a tool for pairing a new dongle, hopefully that will work as well 

honestly what a ridiculous flaw in such a expensive headset, I knew it from the start that dongle was far to cheap for a headset like this, not to mention the range is REALLY short.



 

Exact same problem as everyone else on here. My Razer Nari Ultimate has worked completely fine for almost 2 years now, but as of today it keeps dropping out, trying to reconnect, and then fails in the end… Tried dongle in multiple ports but the problem is with the dongle :( What can be done to fix it? Is there software update or is it a hardware malfunction?

i have same bloody issue ive looked through as much as i could without support and havnt found one solution 

Userlevel 2

Razer just broke all our expensive Nari Ultimate headsets with a recent Synapse update as the Synapse software appears to be causing the issue with the headset.

Likely they did this to incentivise us to buy their new Kraken V3 or Blackshark V2 headsets and if those end up lasting too long they will just break those with another Synapse update so we go out and buy their next headset they came out with.

Userlevel 1

Same problem here but my pc still can’t detect it when I connect it wired with the 3.5mm cable. I have no idea what I am  doing wrong

Same problem here. I opened a support ticket. Let’s see what happens.

 

I also tried both the Pairing Utility and the Dongle Recovery tools and both seemed to fix it at first but as soon as you set the headset as your sound device and start something that plays sound like a Youtube video it immediately goes back into the “pairing” mode and keeps connecting and reconnecting.

Userlevel 7

It’s highly likely that the dongle is defective. Please PM me your case number so I can coordinate with the relevant team and check our options. Thank you!

same freaking issue for 2 days now … after 5-10 minute from PC turning on , it starts rapid random disconnect 

Tried everything , connect reconnect the USB , uninstall install the synapse aaand still happening .

Randomly it starts working again but then disconnects after a while

 

…. is there any solution ?

So there’s 2 problems that seem to cause this;
one is the known, that usb dongle just isn’t pulling enough juice and that “fuse” isn’t a fuse at all, it’s a resistor and bridging it is increasing the power (not entirely recommended)
secondly is weirdly the in the right ear cup, the circuit that controls the master volume, specifically the potentiometer itself.

You can determine which one is a problem by fiddling with the volume wheel and if the disconnects either stop or discernably change in frequency, then it’s the potentiometer and it needs to be replaced. If twiddling the wheel does nothing then the dongle is bad. The protocols of the dongle could be cracked and replicated mostly easily and replacement dongles could be fabricated. Razer could also give us schematics to aid repair and software to pair some generic replacement 2.4ghz dongles too, but razer aren’t a fan of you repairing their products, they’d prefer if you just spend hundreds more on the next device that’s designed to break/fail in 15~ months. Razer being anti-repair S.O.Bs and I can’t wait til they have to change their tune when the lawman comes

Hi I am having the same issues My Nari Ultimate keeps disconnecting and reconnecting. Everything is updated even razer synapse.

Hi I am having the same issues My Nari Ultimate keeps disconnecting and reconnecting. Everything is updated even razer synapse.

 So I am pretty sure it is a razer sypnase update issue. Going to attempt a uninstalling Sypnase and use my headset without the app, hope it works.

Seeing how this thread is over 2 months old and seemingly no solution has been offered  - Correct me if i’m wrong but I’m quite convinced that when @Razer.Zionzedd azer.Zionzedd asked for S/N to “check available options” he is most likely just going to check if it’s within warranty.  My product is out of warranty, yet has no physical damage and “broke” completely random without any physical contact (the receiver just sits in the usb, there’s nothing wrong with the port..) 

Add to this, the amount of people itt with the same problem - this is either a sw issue (another case of synapse being a terrible piece of garbage) or it’s an embarrassingly obvious case of planned obsolescence.

 

Surprise me @Razer Admin  - though I doubt this will happen. Having owned countless of razer products, ever since the first boomslang was released in the UK, yet have never really been acknowledged by razer as an appreciated customer. nor received the support required as of the past few years, I’ll be changing peripherals provider going forward.

 

No more of this, goodbye razer.

my headset stopped appearing at the audio section and it keeps disconnecting from my pc and i tried everything to fix the problem but i can't find a bloody sollution

Having the same issue and it just started couple days ago. PMd informations on the Dongle already. 

 

Wondering if Win10 update didnt break it *ponders*

 

nyways, ill wait for support official statement.

This is happening to my headset as well connects and disconnects over and over...

This is happening to my headset as well connects and disconnects over and over...

noticed that it seems to stay connected fine if I continue to use another headset but the moment I make them my default device it will last for maybe a minute or 2 then start disconnecting and reconnecting.

Same issue with disconnecting sent my info in.

Hi boys, i have given up fixing this issue, i bought new dongle from china, used paring utilities to the new dongle, same problem still exist. Replaced battery to brand new high capacity battery, nothing change except weight.

 

Some of you mention to use it without sypnase,  it will still happen. Fresh windows, ps5(impossible to have sypnase), even ubuntu.

 

I own this headset since 2019. I don’t think is related to hardware, more like firmware that broke our headset. 

 

summary, don’t spend money to replace the dongle as it is a waste, solution for now is only wired mode.

 

p.s battery upgrade mod is worth it if your headset still works wirelessly

Reply