Razer Ornata Chroma keys randomly stopped working? | Razer Insider

Razer Ornata Chroma keys randomly stopped working?

  • 26 August 2020
  • 6 replies
  • 2328 views

Hey guys!

Hoping that someone has had this issue or can point me in the right direction on how to resolve this issue.

Certain Keypad buttons do not work. keys "4, 5, 6, +, -, num lk, /, *, ., home, and page up " are not functioning. I've used the caps lock and escape reset method. I've reset the keyboard in Synapse as well. Uninstalled the drivers, uninstalled Synapse, reinstalled Synapse, and created new keyboard profiles. I'm not really too sure what else to do? I'd love to reflash the firmware to see if that resolves it, but, unfortunately, I can't seem to figure out how to do that.

This happened randomly, I didn't drop, hit, or spill anything on the keyboard.

Yesterday the keys randomly started working again and have now stopped. They were working for a single day.

Any other methods to fix that I might be missing?

This topic has been closed for comments

6 Replies

Having the same issue with my Ornata chroma. top keys from 1 to » stopped working for no reason and I've tried everyting you listed there... Would really appreciate a solution for this since my warranty has ended.
Userlevel 7
leetLavenderMistfun337
Hey guys!

Hoping that someone has had this issue or can point me in the right direction on how to resolve this issue.

Certain Keypad buttons do not work. keys "4, 5, 6, +, -, num lk, /, *, ., home, and page up " are not functioning. I've used the caps lock and escape reset method. I've reset the keyboard in Synapse as well. Uninstalled the drivers, uninstalled Synapse, reinstalled Synapse, and created new keyboard profiles. I'm not really too sure what else to do? I'd love to reflash the firmware to see if that resolves it, but, unfortunately, I can't seem to figure out how to do that.

This happened randomly, I didn't drop, hit, or spill anything on the keyboard.

Yesterday the keys randomly started working again and have now stopped. They were working for a single day.

Any other methods to fix that I might be missing?


Hey guys! I have the same keyboard and I love this model. However, if you've reset the device via Synapse 3.0 or performed the manual keyboard reset on this link, then it's a possible hardware issue. Have you tried disabling or closing Razer Synapse 3.0 and check if the issue persists? Also, try connecting the Razer Ornata Chroma to a different USB port or computer and observe.
Razer.SpeedCr0ss
Hey guys! I have the same keyboard and I love this model. However, if you've reset the device via Synapse 3.0 or performed the manual keyboard reset on this link, then it's a possible hardware issue. Have you tried disabling or closing Razer Synapse 3.0 and check if the issue persists? Also, try connecting the Razer Ornata Chroma to a different USB port or computer and observe.

Connected it to 2 different computers and issue continues (computers that didn't even had synapse installed)...
Userlevel 7
DrJeckyl
Connected it to 2 different computers and issue continues (computers that didn't even had synapse installed)...


It looks like a hardware issue. Have you tried performing the steps on this link? By the way, when and where di you buy the keyboard? Also, what region/country are you from?
Yes, tried the steps and as soon as I removed the fingers from both keys, all lights went out. Every button I pressed lighted up individually and the keyboard seemed to have a huge lag. Unplugged it and plugged it back in and it was working "normal" again, all lights back on again and all keys working with the exception of the ones having the issue.

Bought the keyboard almost 2 years ago in Portugal. It's still under warranty (we have a warranty period of 2 years) so I sent it to the seller so they can send it to the manufacturer to repair/replace... As soon as I described the issue to them on the phone, they immediately asked me to send it to them, probably not the first one to complain about it... Nonetheless, thank you for you help.
Userlevel 7
DrJeckyl
Yes, tried the steps and as soon as I removed the fingers from both keys, all lights went out. Every button I pressed lighted up individually and the keyboard seemed to have a huge lag. Unplugged it and plugged it back in and it was working "normal" again, all lights back on again and all keys working with the exception of the ones having the issue.

Bought the keyboard almost 2 years ago in Portugal. It's still under warranty (we have a warranty period of 2 years) so I sent it to the seller so they can send it to the manufacturer to repair/replace... As soon as I described the issue to them on the phone, they immediately asked me to send it to them, probably not the first one to complain about it... Nonetheless, thank you for you help.


I see. Thanks for letting me know. I glad that it was still covered by its limited warranty. Don’t hesitate to send me a PM or visit our self-help options should you have other questions or concerns. You're welcome. I'll be locking this thread now.