Razer Ripsaw HD Red and Green Tint Issue | Razer Insider

Razer Ripsaw HD Red and Green Tint Issue

  • 19 April 2020
  • 1 reply
  • 43 views

Hey guys,

I got a Razer Ripsaw HD to stream some games and for some reason the input to the monitor looks like the image below. Everything is in a Red to Green tint.

I have already talked to Razer Support and they suggested exchanging it and a new device has the same problem. So clearly the issue is not the Razer Ripsaw. I have a Razer Laptop 14 with a 1060 inside attached to a Razer Core X with a 2080 Super inside. I've tried hooking it up to the Razer Core X directly and the laptop directly by itself. So what am I missing?

Edit #1:

Okay so messing with the Nvidia Color Settings causes things to happen!

It doesn't fix it, but it changes the colors. If I change it back to "With the video player settings" it goes back to red. Anyone got an idea where you can manipulate this directly? Looks like a software issue.



Edit #2:

I GOT IT.

I had to manually add an RGB color profile to my laptop monitor for it to work.

Dear Razer, I appreciate you want this device to have plug and play but you need to patch this device to have selectable color profiles like the Elgato. It should not be THIS DIFFICULT to fix this.


Edit# 3:

UGH!

Okay so plugging back in the Razer Raptor 27 into the Razer Ripsaw brings back the red and green. It appears the RGB laptop and YCbCr422 Razer Raptor 27 color modes between the two are arguing with the Ripsaw's ability to auto-detect a color profile.

Again Razer, please add output settings to the Ripsaw.

This topic has been closed for comments

1 Reply

Userlevel 7
Please refer to the response I sent you on this thread. *Consider this thread locked for multiple self bumps.