Razer Synapse 2.0 Orbweaver Chroma not detected | Razer Insider

Razer Synapse 2.0 Orbweaver Chroma not detected

  • 5 August 2019
  • 7 replies
  • 12 views

So I have been using the Razer Orbweaver Chroma for about 3-4 months with Razer Synapse 2 (legacy edition), I had configured my macros for some 3D software I use for work and for some games too. I currently added a Razer Blackwidow Elite to the mix so I had to download Synapse 3, everything was going well until the latest Windows Update, where Synapse 2 stopped recognizing the Orbweaver Chroma. Windows devices recognizes it automatically and downloaded drivers as soon as it plugged in and Synapse 3 visualizer even expands onto the Orbweaver but I can no longer set any macros or switch profiles. I have tried erasing all razer files and software from my pc and reinstalling it, downloading the MS Windows hotfix “Update for Universal C Runtime in Windows” as per the Razer Orbweaver Chroma support page but to no effect.
Anybody knows how to fix this issue or if it is being looked into? its an expensive piece of hardware to just have laying around, but most importantly its messing with my workflow.
Thanks in advance, and sorry for any broken english (not my first language)

This topic has been closed for comments

7 Replies

Userlevel 7
Rezvant
So I have been using the Razer Orbweaver Chroma for about 3-4 months with Razer Synapse 2 (legacy edition), I had configured my macros for some 3D software I use for work and for some games too. I currently added a Razer Blackwidow Elite to the mix so I had to download Synapse 3, everything was going well until the latest Windows Update, where Synapse 2 stopped recognizing the Orbweaver Chroma. Windows devices recognizes it automatically and downloaded drivers as soon as it plugged in and Synapse 3 visualizer even expands onto the Orbweaver but I can no longer set any macros or switch profiles. I have tried erasing all razer files and software from my pc and reinstalling it, downloading the MS Windows hotfix “Update for Universal C Runtime in Windows” as per the Razer Orbweaver Chroma support page but to no effect.
Anybody knows how to fix this issue or if it is being looked into? its an expensive piece of hardware to just have laying around, but most importantly its messing with my workflow.
Thanks in advance, and sorry for any broken english (not my first language)


Hi there! Thanks for posting your concern here. Sorry to hear about the odd behavior of your Razer Orbweaver Chroma. Let's figure this out. By the way, does the issue happen while connecting the gaming keypad to a different USB port or to a different computer with Razer Synapse 2.0 installed? Please create a dummy Razer Synapse account and see if the issue still persists.
I updated my legacy 2 and my Orbweaver isn't recognized. I have tried everything to get it to connect and same thing not connecting. Anyone have answer for this?
I have this problem on different desktops and laptops.
Already for months now!!!!
It sometime works to clear all files from your pc and do a clean install. but not every time??
If you do a format c: and re-install win. then it works for some time but not long
I am almost 100% sure that there is something wrong whit the software.
Win drivers are working an device is ready if I plug it in. synapse 2.0 is ready only it dos not find the orbweaver.
I'm ready to throw out all my razer devices and buy some good things that will work for more than on week!!!

razer please fix this software for you devices on the 2.0
stizzler200
I have this problem on different desktops and laptops.
Already for months now!!!!
It sometime works to clear all files from your pc and do a clean install. but not every time??
If you do a format c: and re-install win. then it works for some time but not long
I am almost 100% sure that there is something wrong whit the software.
Win drivers are working an device is ready if I plug it in. synapse 2.0 is ready only it dos not find the orbweaver.
I'm ready to throw out all my razer devices and buy some good things that will work for more than on week!!!

razer please fix this software for you devices on the 2.0



Yep Fresh windows install did the trick but for for how long this is just stupid.
Userlevel 7
X_Metal_X
Yep Fresh windows install did the trick but for for how long this is just stupid.


Thanks for pointing that out. You can use the feedback section in your Razer Synapse so you can directly forward it to our Developers. Also, should the issue recur, please send me a PM so I can further assist.
Hey,

I have don a clean install from win 10 and synapse 2.0 and the software is not detecting my device.
Win install the device as an normal usb and proms that it is ready to use.
And it is still not found????????
Hardware is working as a regular keyboard so the hardware is ok
please make some proper software or at least a hotfix
Userlevel 7
stizzler200
Hey,

I have don a clean install from win 10 and synapse 2.0 and the software is not detecting my device.
Win install the device as an normal usb and proms that it is ready to use.
And it is still not found????????
Hardware is working as a regular keyboard so the hardware is ok
please make some proper software or at least a hotfix


Hi there! Please send me a PM together with your device serial number and a screenshot of your device manager under mice, keyboard, USB devices and HID-compliant device to see if there any duplicate driver created in the list. Let's continue from there.