White Spots on Screen Razer Blade (2017) | Razer Insider

White Spots on Screen Razer Blade (2017)

  • 18 June 2019
  • 3 replies
  • 48 views

Hi,

I have a Razer Blade purchased late-2017 which I've noticed five white 'spots' in the middle of the screen. Can someone tell me what these are and if they're likely to go away?The spots appear to be exactly where the logo is on the lid, specifically corresponding where the snakes curve, I think.

The laptop is basically never moved and is therefore in perfect condition with no damage whatsoever (at a glance you'd probably think it was box new) so this is very annoying. I don't actually really use the screen but an external display so I can't say exactly when they appeared but think it was recently.

Really question the build quality of Razer stuff with things like this. Also just had my second blade power supply stop working too, they can't seem to handle a year without failing :slightly_sad:


This topic has been closed for comments

3 Replies

Userlevel 7
Thanks for sharing this with us. Did they've mentioned reverting your laptop's operating system back to its factory default to further isolate the issue? Also, have they created a case ID and escalated the case to our Support Team? Oh, those are my peers from Reddit Team! Please send me a PM together with your Reddit username and email address so I can cross-check our system and backtrack what they have asked and suggested to you in regards to your laptop's white spot concern.
Razer.Speedcr0ss
Hey there! Let me help you out with this. When did this white spot start appearing in your middle screen? Is there any software or hardware changes happened recently? Does the issue happen even when your laptop is turned off? Have you tested the laptop on an external monitor and see if the issue persists? Please ensure that you have updated to the latest version of Windows by going to Settings > Update & security > Windows Update, and select Check for Updates and apply if necessary. Lastly, please conduct a pixel test and look for any defective pixel by clicking this link.


Hi, I noticed the white spots a few days ago, there have been no hardware changes, the issue doesn't happen when the laptop is off (the screen is off and black), Windows is up to date, I have done a pixel test there are no dead pixels. It can only really be seen on a white screen (very, very faintly on coloured screen and not on black), I have uploaded another image here:



I contacted support on Reddit initially but have so far been replied to by: Tala M, Jace S, Jimmy M, Mae L, Rose Z who keep just asking me the same questions when I just need a solution...
Userlevel 7
Hey there! Let me help you out with this. When did this white spot start appearing in your middle screen? Is there any software or hardware changes happened recently? Does the issue happen even when your laptop is turned off? Have you tested the laptop on an external monitor and see if the issue persists? Please ensure that you have updated to the latest version of Windows by going to Settings > Update & security > Windows Update, and select Check for Updates and apply if necessary. Lastly, please conduct a pixel test and look for any defective pixel by clicking this link.