Error that Kraken V3 Pro is not recognized in Synapse Beta | Razer Insider
Question

Error that Kraken V3 Pro is not recognized in Synapse Beta

  • 13 January 2024
  • 5 replies
  • 871 views

I don't know if I'm the only one experiencing this problem, but since updating to Synapse Beta, Kraken V3 Pro is not recognized by Synapse.

Not only that, but it is not recognized in Razer Chroma Beta. However, the headset is recognized by the computer and operates normally. Does anyone know a solution to this? I've already tried all the firmware updates and even reinstalled Synapse.


5 Replies

Same here! It's extremely frustrating. Synapse 3.0 had also given me loads of issues with it. Sometimes it recognized it, sometimes it didn't. But the Beta won't recognize it at all.

Firmware is completely up to date on both the headset and dongle. I don't know what else to do. I've submitted a ticket and I hope they respond but I'm starting to seriously regret buying this headphones because of this.

 

Userlevel 1

As far as I’m aware, they’re not on the supported on the Beta yet, I’m shocked that a newer headset model isn’t on there yet, it’s rather frustrating. 

I’ve not had any issues with the headset, other than the Beta doesn't pick them up due to not being supported yet. I keep refreshing this page to see if they’re supported: 

 

Feb was supposed to be the day for more razer products , for some reason i remember seeing something about the kraken v3 pro coming to the synapse 4 but it seems like that was a lie

Userlevel 1

Feb was supposed to be the day for more razer products , for some reason i remember seeing something about the kraken v3 pro coming to the synapse 4 but it seems like that was a lie

I think it was supposed to come on the update in February, but that’s not happened. Annoying isn’t the word… I’ve been debating reverting back to Synapse 3.

Yeahh big disappointed there, If your gonna go back then be careful, for some reason The kraken V3 pro tends to disconnect all the damn time, and the get it to pop back up you have to restart your computer or restart synapse, like Going into task manager and Stoping all processes 

Reply