Razer Blade 18 Firmware and Blade 16 and 18 Screen Flicker and Image Retention Updates | Razer Insider
Sticky

Razer Blade 18 Firmware and Blade 16 and 18 Screen Flicker and Image Retention Updates

  • 7 March 2023
  • 19 replies
  • 1413 views

Userlevel 7

Hey Everyone, 

For those of you experiencing trackpad issues and palm rejection on the Blade 18 there’s a new firmware update that may help resolve those issues: 

Razer Blade 18" (2023) | RZ09-0484x Support

 

Furthermore, for those of you with Screen Flicker and Image Retention issues on your Blade 16 and 18, there’s an update here:

Razer Blade 16” (2023) and Razer Blade 18” (2023) screen flicker and image retention

 


19 Replies

I had image retention like 2 - 3 times in a day, I just installed the last firmware, I will keep you informed if I am still having this issue

I had image retention like 2 - 3 times in a day, I just installed the last firmware, I will keep you informed if I am still having this issue

I am still ahving this issue My image freezes once or twice a day if at all. And I have to press shift+control+windows key + B to get it to work again after 30 seconds, it's very annoying. When will there be a definitive solution? This patch didn't help me at all, I followed all the instructions. I have the version with the 4080

Userlevel 7

@hackeame I sent you a PM asking for the serial number so I can check on your device and escalate your concern to the relevant team. I am looking forward to hearing back from you soon. Thanks!

And also some info it’s like always happening in the middle of a video meeting, like teams, zoom, or something like that. 

I have two questions. #1 is the flicker issue confined only to the Blade 18 and Blade 16 with mini LED or does the hotfix also need to be applied to the Blade 16 with IPS display? #2 I also wonder if new orders from Razer are still experiencing this issue or if there will be a full resolution in the future allowing the use of graphics switching?  If so, is there any real world disadvantages (OTHER THAN BATTERY) that can come from GPU only mode, as I will use my laptop for video editing and programs other than gaming. 

has anyone found a legit webcam slide for the 18  its amazing razer dosent make one

@hackeame I sent you a PM asking for the serial number so I can check on your device and escalate your concern to the relevant team. I am looking forward to hearing back from you soon. Thanks!

I just send you all the details you need, please I need help with it, it’s happening almost everyday, today happend twice, image freezed and the only thing left to do is restart the pc.

Userlevel 2

I have applied this hotfix to my Razer Blade 16” (Part No. RZ09-0483) and before I noticed a limited amount of image retention.  Now it’s so bad that all blacks bleed across the page for moment while scrolling.  Can someone in Razer fix let me know how to fix this.  This expensive a laptop shouldn’t be having this problem.

 

Thank you!

Userlevel 7

I have applied this hotfix to my Razer Blade 16” (Part No. RZ09-0483) and before I noticed a limited amount of image retention.  Now it’s so bad that all blacks bleed across the page for moment while scrolling.  Can someone in Razer fix let me know how to fix this.  This expensive a laptop shouldn’t be having this problem.

 

Thank you!

 

That’s inconvenient. Were you able to contact our Support Team? If you haven’t, please send me a PM so I can help you kick-start an investigation. Thanks for your cooperation.

There was a beta firmware (v5) issued a week or so ago for the screen, and in my excitement I installed it carefully following the instructions which stated that the update would take 20 minutes.  I waited 40 minutes and yet the progress indicator was stuck at about 80% or so.  After about 50 minutes, I tried rebooting the system and while I can hear it reach the Windows login, the screen remains blank.

 

I was hoping they would issue an updated firmware that perhaps I can plug my laptop to an external monitor to install.

 

Anyone else try the update?

Userlevel 1

I installed the beta firmware fine on my Blade 16 4070 mini led cause I have the blooming issue as well, but now the screens contrast and saturation just looks worse than how it was before. I can also see some weird shadowy artifacting around moving things like my cursor. Hdr now just looks like a brightness filter now except the helps tone down the overblown colors a good amount. Blooming is much better and blacks do look proper but man I’d prefer the older firmware I had before since the gamma/contrast, saturation, etc. just looks so much worse now. 

Id try connecting the blade to an external monitor to see if that works in your case

Thanks for your input.   I was thinking of connecting to an external monitor to update the firmware.  Trouble is, they removed them the day after (they must know it’s no good).  I have the Blade 16 w/ 4080.

 

How long did yours take to update?  Did it have some popup indicating completion?  I waited for over 50 minutes, while the instructions said it takes 20 minutes.

Userlevel 1

I found the update here, someone on reddit had posted it https://mysupport.razer.com/app/answers/detail/a_id/13533

Id say my update took 15 ish minutes, After the progress bar was at the end, my laptop restarted and it was completed 

Thanks for the link.  I will try as soon as I get a chance.  My attempt stalled at around 80% or so and didn’t move beyond that.

What is going on with updates? I’ve noticed two updates for B16: touchpad and bios. And now they have gone from site. Did it contain bugs, and you hide them or what? 

Interesting, the v1 for the panel hotfix is back.  Perhaps I will try that first (as maybe my model configuration may not be entirely compatible w/ the v5) when I get a chance.  But it is notable that v1 specifies nVidia driver version to use while updating, whereas I don’t recall v5 doing that.

image is clear for my opinion..

Download Link don´t work https://mysupport.razer.com/app/answers/detail/a_id/13533https://rzr.to/0m5wSm :(

I tried to connect my Razer Blade 16 (2023 w/ 4080) to external monitor (TV) through HDMI and tv just says “no signal”.  v5 beta for the firmware upgrade specified to switch setting to “dedicated graphics” which is the nVidia, so w/ the update failure, does that mean there’s no way to use the external connection to try to re-update back to v1?

Reply