Core X Chroma keeps disconnecting randomly | Razer Insider
Question

Core X Chroma keeps disconnecting randomly

  • 23 August 2023
  • 0 replies
  • 311 views

Hello everyone. On June 18, 2023, I bought a Razer Blade 15 Advanced Model (Mid 2021) laptop from Razer - RZ09-0409

I already have one, but it no longer functions after six months of work and I had to buy a new one. For now, I'll be using it in conjunction with the Core X Chroma that I bought from Razer less than a year ago.

Every day, several times a day, my external card simply disconnects for no apparent reason. The card is still receiving power.

This shit didn't happen with my last laptop. But with the new one it is.

I wonder if you have at least one product from this company that works properly?

Anticipating the question, I have already done the following and the problem still remains:

Reset the Razer Core

Unplug the Razer Core from your Blade by removing the Thunderbolt cable

Shutdown the Blade system and also power off Core’s power supply

Let both Blade and Core remain in Power OFF (O) state for 30 seconds

After 30s, Power ON (|) Core’s power supply

Plug the Razer Core to your Blade via Thunderbolt cable

Power ON your Blade system

Uninstall the Thunderbolt Software

Go to the following page: Blade Stealth (6500U) // Blade Stealth (7500U)

Download the Thunderbolt file available

Once done, open up Control Panel (right click on the Start Menu)

Gos to Programs and Features

Locate and uninstall the Thunderbolt Software

Once done, restart the system before installing the downloaded file

After this is done, connects the Razer Core back again. By right, the Thunderbolt Software should prompt up and request for you to set the connection detail (choose Always Connect).

Afterwards, Synapse will recognize the device and run a few updates for the Core. Let the Core stay connected and the update be completed first before disconnecting the Core and attaching the GPU once again.

Install the necessary Drivers

Go to http://www.geforce.com/drivers

Download the necessary driver for your graphics card

Connect the Razer Core to the System and run the downloaded installer

Choose to run the custom installation and clean install the following only:

Display Driver

PhysX

HDAudio

WiFi/Ethernet You can also try to change up your Internet connection settings and see if this changes the behavior of your unit. If you are able to, you can set your Razer Blade to always prefer a 5gHz bandwidth instead of a 2.4gHz one. Alternatively, you can also try to use an Ethernet cable instead of WiFi.


Is there anyone here from the company who could give me an answer to the question of why the hell I have to waste time, money and nerves on all this shit? 


0 Replies

Be the first to reply!

Reply