Razer blackshark v2x usb not detected in synapse v3 | Razer Insider
Question

Razer blackshark v2x usb not detected in synapse v3

  • 5 March 2023
  • 5 replies
  • 925 views

Good day,

Can somebody help me, my razer blackshark v2x usb version is not detected in my synapse v3. Tried restarting my laptop and reinstalling the application. My razer basilisk x hyperspeed is detected. I am just having problem with the blackshark v2x usb


5 Replies

It sounds like you've tried some initial troubleshooting steps already, such as restarting your laptop and reinstalling the Synapse v3 application. One thing you might try is to check if your Razer Blackshark V2X USB is properly connected to your laptop. You could also try plugging it into a different USB port on your laptop, as this can sometimes help with connectivity issues.

But one thing does the Blackshark v2X usb detectable in the razer synapse v3?

i did it : uninstall synapse 3, use Device Detection Troubleshoot Tool 1.0.0.8 from razer, reboot and install an older synapse 3 (from another post with this links https://www.filehorse.com/download-razer-synapse/50060/download/) and it works for me

Hi All, had a similar issue on my wired death adder 2 and Black widow V3 Mini, diver errors on windows after synapse update, following the link in this thread and installing the older version fixed my issues! THANKS!

I have the same problem but installing the old version didn’t help

 

Reply